5

Since Lenovo have decided to place the Home and End keys in unreachable locations on my Thinkpad, I use the numeric keypad for these. With NumLock off, 1 = End and 7 = Home. One typical use for this is to select text from the current cursor position to the end of the line (Shift + (numpad) 1).

This used to work fine until very recently, after I installed updates and rebooted. Now Shift + (numpad) 1 just prints the character "1".

I found an option in the system settings: Keyboard > Advanced > Miscellaneous compatibility options > Shift with numeric keypad keys works as in MS Windows. This option fixes the problem (restores the way it worked before), but also changes my H key to type "W", which is quite inconvenient, as you can imagine. All other keys work like before.

This only occurs with the German keyboard layout, not the default US layout.

What to do?

System: Lenovo Thinkpad W550S, Kubuntu 15.10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.