0

I'm on a fairly new install of 15.10 and I noticed in gedit that I have no list of recently opened files. "~/.local/share/recently-used.xbel" is there and writable but the contents are the following:

<?xml version="1.0" encoding="UTF-8"?>
<xbel version="1.0"
      xmlns:bookmark="http://www.freedesktop.org/standards/desktop-bookmarks"
      xmlns:mime="http://www.freedesktop.org/standards/shared-mime-info"
></xbel>

If I open a file in gedit the timestamp on the file changes so something is being done with the file but the contents never change.

Edit:

I thought to try running gedit via the terminal to see if there were any error messages. When I closed gedit I got the following (though I suspect they have nothing to do with this issue):

** (gedit:5614): CRITICAL **: gedit_multi_notebook_get_active_tab: assertion 'GEDIT_IS_MULTI_NOTEBOOK (mnb)' failed

(gedit:5614): Gtk-CRITICAL **: gtk_action_group_get_action: assertion 'GTK_IS_ACTION_GROUP (action_group)' failed

(gedit:5614): Gtk-CRITICAL **: gtk_action_set_sensitive: assertion 'GTK_IS_ACTION (action)' failed
7
  • 1
    What are permissions for recently-used.xbel? Maybe it isn't writable? ls -al tells me mine is -rw-------.
    – DK Bose
    Feb 5 '16 at 13:14
  • @DKBose - I have the same permissions. If it was a permission issue it probably wouldn't update the file timestamp. Feb 5 '16 at 13:42
  • What about the contents of settings.ini in ~/.config/gtk-3.0 or /etc/gtk-3.0? Is there something like gtk-recent-files-limit=0 in there? But that should affect all gtk3 apps.
    – DK Bose
    Feb 5 '16 at 14:45
  • 1
    Please check > System Settings > Security & Privacy > Files & Applications > and make sure that Record file and application usage is enabled.
    – doug
    Feb 5 '16 at 14:45
  • @DKBose - I think this IS affecting all gtk3 apps, I just don't have much installed yet. GIMP shows no past history too. I don't have any home directory gtk settings.ini file and there's no files-limit setting in /etc/gtk-3.0. I'm assuming the default isn't 0, right? Feb 5 '16 at 14:57
2

If Gedit and Nautilus aren't showing any Recent entries & ~/.local/share/recently-used.xbel is no longer being written to then most likely from changing the default Privacy settings.

To check open System Settings > Security & Privacy > Files & Applications > and make sure that Record file and application usage is enabled.

0

Under Linuxmint Cinnamon, this is under Preferences > Privacy

The default setting for "Remember recently accessed files" is OFF.

I turned that ON, and set "Never forget old files" to ON, also.

I opened GIMP and Inkscape several times, & when I opened recently-used.xbel, I found this: (stripped out most lines)

<bookmark href="file:///home/homer/Untitled.xcf" 
<bookmark href="file:///home/homer/Untitled.png"
<bookmark href="file:///home/homer/Desktop/1Pictures/Screenshot%20from%202019-08-10%2018-51-38.xcf" 
<bookmark href="file:///home/homer/puzzles/3_simultaneous_equations/PuppyTortoiseChook.svg"

This appears to have fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.