2

I already follow these instructions provided in Ubuntu StackExchange and display is still reset to minimum after restarting.

1-

cat /sys/class/backlight/acpi_videoX/brightness
gksu gedit /etc/init/fixbrightness.conf
description "Sets brightness after graphics device is loaded"
start on graphics-device-added
task
exec /bin/echo BRIGHTNESS_VALUE > /sys/class/backlight/acpi_videoX/brightness

2-

cat /sys/class/backlight/acpi_video0/max_brightness`<br>  
gedit /etc/rc.local`

Add the line below before the last. Change the number 0 to the brightness level you want.

  echo 0 > /sys/class/backlight/intel_backlight/brightness
#I set 9 here.

3- Update Grub file, line no 11 in /etc/default/grub to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
update grub using the command
update-grub

4-

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf
sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following lines to this file:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

5-

sudo add-apt-repository ppa:nrbrtx/sysvinit-backlight
sudo apt-get update
sudo apt-get install sysvinit-backlight

Im using intel video card for brightness. Backlight found at:

/sys/class/backlight/intel_backlight
0

I resolved the issue of display brightness reset to the minimum after restarting. Remove all configurations made, number 1, 2, 4, and 5 and only apply instruction number 3. However, it sets to maximum brightness every restart and changing of brightness level doesn't work. It's okay for me now, instead of having a minimum display brightness every time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.