3

I'm happily running my LAMP stack with php 7.0 except that I require uploadprogress.so and attempts to install it with PECL result in compile errors.

What do I need to tell Ubuntu 14.04 to use the correct libraries etc to compile uploadprogress.so?

2

Depends on how you installed PHP 7.0:

  • From ppa:ondrej/php - just do apt-get install php-uploadprogress
  • From sources - you need to build the extension from current git tree:

    git clone git@git.php.net:/pecl/php/uploadprogress.git
    phpize # just make sure the default phpize belongs to PHP 7.0
    ./configure
    make
    sudo make install
    
2

php-uploadprogress is not available by default on Ubuntu 16.

sudo apt-get install php-uploadprogress
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php-uploadprogress is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'php-uploadprogress' has no installation candidate

What is the best way of installing so that any updates will be installed in the future?

I found a possible solution... https://www.drupal.org/node/2718253

You can also try...

With this PPA the installation of the upload progressbar for PHP 7 should work also.

sudo add-apt-repository ppa:ondrej/php

Followed up by this command

sudo apt-get update

Then the uploadprogress for PHP7 can be installed via:

sudo apt-get install php-uploadprogress
  • If You find that command add-apt-repository doesn't exist then install it with: $ sudo apt-get install software-properties-common python-software-properties – sobi3ch Nov 11 '16 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.