3

I've been trying to install github-pages using gem. I have Ruby v. 2.1.2:

✦ ruby -v
ruby 2.1.2p95 (2014-05-08 revision 45877) [x86_64-linux]

I installed Ruby using RVM and I've set 2.1.2 as my default version to use. Somehow, I'm still getting this error message:

✦ sudo gem install github-pages
    ERROR:  Error installing github-pages:
    jekyll requires Ruby version >= 2.0.0.

Any ideas?

0

Moved OP'solution left in the question into a Community Wiki Answer

My end goal was to install Jekyll. Github-pages was not cooperating. Instead, I installed Jekyll directly with:

gem install jekyll

https://jekyllrb.com/docs/installation/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.