0

I recently installed wine to play some steam games I thought looked interesting, the program itself launches and you have the normal steam menu but if you click on store, or community then it just loads but dose nothing from there. I have tried uninstalling wine and re installing but same results. The picture is so you can see what I am talking about. It is a 64bit but I do not know how to make it a 32bit and have tried everything I found on askubuntu.

enter image description here

enter image description here

  • why pick the worst method? you are better off installing steam in windows in vbox. or use a dual boot. or install steam in linux (but that will limit the amount of games). wine is the worst thing to use for gaming though. – Rinzwind Mar 6 '16 at 0:12
  • @Rinzwind Wine works pretty well for games, actually (I used to use it for Minecraft with similar FPS). – QwertyChouskie Mar 6 '16 at 0:14
  • Have your tried Guild Wars? Or any similar games? Btw: I did not claim it did not work just that I believe it is the worst method ;-) – Rinzwind Mar 6 '16 at 0:17
0

Have you tried the latest version of Wine? From https://wiki.winehq.org/Ubuntu:

If your system is 64 bit, enable 32 bit architecture (if you haven't already):

sudo dpkg --add-architecture i386

Add the repository:

sudo add-apt-repository ppa:wine/wine-builds

Update packages:

sudo apt-get update

Then install (example for the development branch):

sudo apt-get install --install-recommends winehq-devel

If you prefer to use the Staging branch, replace winehq-devel with winehq-staging in the line above.

The version of Wine in the Ubuntu repos is still 1.6, while the latest version is 1.9. It is very likely that the problem has been fixed in Wine already. If this does not help, try:

wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks && ./winetricks ie8

Note that if the default prefix is a 64-bit prefix, you will probably have to delete it, recreate it as a 32 bit prefix, reinstall steam, and re-run the command. To recreate the prefix as 32-bit (THIS WILL REMOVE ALL INSTALLED WINE APPLICATIONS):

rm -r ~./wine && WINEPREFIX=~/.wine WINEARCH=win32 wineboot
  • I ran all of those commands in terminal but still the same results how do I completely remove both wine and steam? – Npost Feb 3 '16 at 23:57
  • I updated the answer with instructions to make the prefix 32-bit. – QwertyChouskie Feb 4 '16 at 4:10
  • I fixed the command for recreating the prefix, try it again. – QwertyChouskie Mar 6 '16 at 0:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.