2

I have recently noticed that for some reason when pressing CTRL in a VM in VirtualBox it doesn't get through... So I can't easily copy and paste etc, it just doesn't get through, the VM doesn't think that I've pressed anything when I press CTRL or at least it doesn't do anything, why is this? It doesn't seem to matter what I run as guest, and it didn't happen before with these same VMs so it's not that they all just don't like it, the problem probably is with VirtualBox. I have tried running Ubuntu GNOME 15.10, Ubuntu 16.04, and Ubuntu GNOME 16.04.

Information Update:

Neither the left, nor the right CTRL keys actually do anything, they don't even seem to interact with Virtual Box because pressing the right one should change something in it.

I have tried installing the Guest Additions CD in my VMs, but it makes no difference to my problem.


OS Information:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.10
Release:    15.10
Codename:   wily
Flavour: GNOME
GNOME Version: 3.18

Package Information:

Version: 5.0.14 r105127
  • 1
    VB uses left ctrl for controlling guest, right ctrl for host. That way you can use ctrl left for your guest os, and right for controlling vbox window – Sergiy Kolodyazhnyy Feb 3 '16 at 22:24
  • @Serg: Well, neither of them seem to do anything in VB/VM... – user364819 Feb 4 '16 at 16:20
  • May be a version bug. I'm on 14.04, works alright here:) – Sergiy Kolodyazhnyy Feb 4 '16 at 16:27
  • Could it be a gnome thing?. Maybe the CTRL key is assigned by it to some function. – Javier Rivera Feb 5 '16 at 7:52
  • Already asked on SuperUser: Ctrl key doesn't work in Virtual Box, Linux host – Dan Dascalescu Aug 16 '16 at 17:12
8

I have figured out the problem!

The problem was that for some reason when one has the Show location of pointer option enabled in the gnome-tweak-tool, as this is assigned to CTRL, for some reason this prevents programs from capturing this key. So disabling that option in the gnome-tweak-tool fixes the issue.

| improve this answer | |
  • amazing. how did you figure that out? – towi Jun 3 '17 at 12:15
  • @towi: Because it was the only recent change I had made to the settings in terms of the keyboard and mouse in any way. So I put two and two together and gave reverting the setting a choice and thankfully it worked! – user364819 Jun 5 '17 at 15:12
  • Worked for me in Ubuntu 17.10 (Gnome, Xorg) – apos Feb 6 '18 at 10:07
  • @apos: Yes, I seem to remember hearing about the fix for this bug being released. – user364819 Feb 6 '18 at 20:00
-1

Do you have the guest additions installed? This helps with a lot of these issues.

In the VirtualBox window running your VM:

Devices > Insert Guest Additions CD Image

Or, Right Ctrl + D

Follow the prompts and then restart your VM and it should work.

As others have mentioned, Right Ctrl is the host key by default and as so will not work for copy/paste type actions but the left one works fine.

| improve this answer | |
  • Any keyboard shortcut with "CTRL" in it isn't going to do me that much good... :P – user364819 Feb 3 '16 at 22:10
  • I was thinking your VM might be stuck using the ctrl key for host tasks and that is why ctrl isn't working within the VM. Using right ctrl + D executes on the host, not the VM in my understanding (specifically the right one, not left) – Patrick Schaefer Feb 3 '16 at 22:15
  • Ok, anyway, I have tried install Guest Additions, but it still doesn't work... – user364819 Feb 4 '16 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy