0

Gparted worked fine in Ubuntu 14.04 and 14.10 (I'm not sure about 15.04)) but I'm having trouble installing it in 15.10 from the software center. It gives the error: “Package dependencies cannot be resolved.” I tried the following answer suggested in the forum posting “Gparted not working”:

Try removing these packages gparted libatkmm-1.6-1v5 libgtkmm-2.4-1v5 libgtkmm-3.0-1v5 pavucontrol type in this command.

sudo apt-get remove gparted libatkmm-1.6-1v5 libgtkmm-2.4-1v5 libgtkmm-3.0-1v5 pavucontrol

and then install ubuntu-desktop if it removes it.

sudo apt-get install ubuntu-desktop gparted libatkmm-1.6-1v5 libgtkmm-2.4-1v5 libgtkmm-3.0-1v5 pavucontrol

But when I did this, I got the following error in the terminal:

The following packages have unmet dependencies:

gparted : libatkmm-1.6-1 (>= 2.22.1) but it is not installable

libglibmm-2.4-1c2a (>= 2.42.0) but it is not installable
libgtkmm-2.4-1c2a (>= 1:2.24.0) but it is not installable
libpangomm-1.4-1 (>= 2.27.1) but it is not installable
libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable

E: Unable to correct problems, you have held broken packages.

Is there a way to find out what is missing and broken?

0

You could try using apt-get instead of the software center

sudo apt-get install gparted

if it still complains about unmet dependencies apt-get can try to fix them with:

sudo apt-get install -f
  • I tried your suggestion but still get the same error of unmet dependencies. Perhaps I'll have to revert to 14.04.? – John Feb 5 '16 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.