2

I'm trying to use ubuntu in my laptop. But the fan seems to not working.. I try use sudo pwmconfig but this is the result..

sudo pwmconfig
# pwmconfig revision 6166 (2013-05-01)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/sbin/pwmconfig: There are no fan-capable sensor modules installed

I also try ~$ lspci -k | grep -EA2 'VGA|3D', the result is this

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)    Subsystem: ASUSTeK Computer Inc. Device 1477
    Kernel driver in use: i915
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 635M] (rev a1)     Subsystem: ASUSTeK Computer Inc. Device 1477
    Kernel driver in use: nouveau

My laptop's temperature is really high, what can I do to fix this?

  • There probably is no fan speed sensor. That's OK. What grapphics adapted do you have? Which driver is used? Anyway the sensor won't help. – Pilot6 Feb 3 '16 at 16:24
  • You have dual graphics. That is why it overheats. Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. PLEASE DO NOT POST IT TO COMMENTS!!!! – Pilot6 Feb 4 '16 at 14:55
  • Is there anything i can do to cool down my laptop? – LearningDummy Feb 4 '16 at 15:03
  • You need to install drivers. – Pilot6 Feb 4 '16 at 15:08
2

You have two graphics adapters in your system. Now both of them are enabled and consume power.

Also the nouveau driver is not good in terms of power.

You need to install proprietary drivers. Run in terminal:

sudo apt-get install nvidia-352 nvidia-prime

and reboot.

You can save more power and make the computer cooler if you switch to the integrated adapter by

sudo prime-select intel

or using GUI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.