1

I just bought a new laptop HP ProBook 450 G3 Notebook PC i7, and installed Ubuntu 15.04 on it, but after installation it's not giving me any options for connecting with Wi-Fi. I have tried every possible solution available on Stack Overflow and the Internet.

Kindly update me with the possible solution or may I switch to Ubuntu 14.04 (Trusty Tahr) or another version to get it working properly?

03:00.0 Network controller [0280]: Intel Corporation Device [8086:3165] (rev 81)
    Subsystem: Intel Corporation Device [8086:4010]

PS: When I don't do anything on the system, and leave it alone, it goes to sleep, but on moving the mouse it just blinks again and again with the login screen. Why is it so?

  • You tried "every possible solution" without even knowing the adapter model? ;-) – Pilot6 Feb 3 '16 at 11:00
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Feb 3 '16 at 11:00
  • Okay sorry am doing it wait a sec – Junaid Farooq Feb 3 '16 at 11:01
  • And why do you install 15.04 that will reach eol in 4 days? – Pilot6 Feb 3 '16 at 11:01
  • which should i install? – Junaid Farooq Feb 3 '16 at 11:02
0

I suggest installing Ubuntu 14.04.3.

After you install the system, connect to internet by wire and upgrade the kernel by running:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install linux-generic-lts-wily

Wi-Fi should work after reboot.

Ubuntu 14.04.4 will support this adapter out-of-the-box. It will be released soon. You do not need to deliberately upgrade to it. Just install regular updates.

  • Okay thanks :) i will update after doing it and that blinking issue is because of? – Junaid Farooq Feb 3 '16 at 11:16
  • This is another issue. If it persists on the new system, then you are welcome to ask another question. – Pilot6 Feb 3 '16 at 11:17
  • i am installing it just want to tell you that while installing it , on startup it showed some notification as iwlwifi failed. – Junaid Farooq Feb 3 '16 at 12:35
  • It is OK. After you upgrade the kernel it should work – Pilot6 Feb 3 '16 at 12:43
  • Hi @Pilot6 can i have you on this? askubuntu.com/questions/732685/no-sound-on-ubuntu-14-04-3-lts – Junaid Farooq Feb 12 '16 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.