0

I have been working for the last four hours to format my external hard drive. At first I tried right clicking on it in nautilus and selecting format. I selected NTFS and tried to format it. I got some error shortly after saying something had timed out. Next I tried formatting it with gparted which is annoying since every time after I use it I get some sort of D-Bus error when I try to access my hard drives. I used gparted to give it the NTFS file system and restarted my computer. When I tried to open the drive in nautilus I got an error about the drive having a pending operation.

Next I decided to try the ext4 format. I got the same error when I tried to format it through nautilus, but it seemed to work when I did it through gparted. I was able to mount the drive and copy some files. This is a backup drive so I went to copy a folder of 600 GB size with some 12000 different files. At first the copy was really fast going at almost 100 Mb per second but at around 2 GB it became painfully slow as in maybe 3 Mb per second. It did not look like much disk activity was happening with my computer and it was just stalling for some reason. I then cancelled the copy and removed the drive. When I plugged it back in I got the pending operation error again.

Next I tried to boot into windows to format it and of course that went horribly as well. The windows format tool either didn't recognize the drive or when it was plugged in actually crashed windows. When I did get the format tool to finally see the drive I tried formatting it and it just said formatting for over an hour.

I would think that this issue may be with my usb drive but I have had similar unresolved nightmares trying to format flash drives on ubuntu 15.10. Also I tried to format it on ubuntu on my other computer and had the same issues. Any advice?

2

I would use gnome-disk-utility formating the drive, not the partition.

Next, (if it is the case) in Windows format in NTFS using Disk Managment.

For the (so many) folder/files copying, grsync is a better choice than simple copy-paste. Pay attention at the Source and Destination "?" pop-up! Do a sync simulation first

1

There are many factors which can influence drive performance. Transferring 12000 files of any size will not be a quick process, and 3 MB/s is a conceivable transfer rate for such a task. It sounds like your hard drive may also be suffering the effects of age. Full formats also are very time intensive, so the quick format option is nearly always your best option.

There is a great article about monitoring and troubleshooting disk problems here: https://help.ubuntu.com/community/DiskPerformance

  • It is an almost brand new drive – chasep255 Feb 3 '16 at 4:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.