1

I installed Ubuntu on the new Lenovo miix 700 and haven't been able to get the wireless working. I used to have to remove and blacklist the ideapad_laptop wireless driver/controller with sudo modprobe -r ideapad_laptop and /etc/.d/blacklist-ideapad.conf to on the previous Lenovo miix model but didn't have luck doing that with this problem.

Kernel Version 3.19.0-25-generic

lshw -C network:

   description: Network controller
   product: Wireless 8260
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: 3a
   width: 64 bits
   clock: 33MHz
   capabilities: cap_list
   configuration: latency=0
   resources: memory:d1500000-d1501fff

When I run ifconfig I don't get a wireless link

[    2.413997] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
[    2.415741] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-17.ucode failed with error -2
[    2.415753] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-16.ucode failed with error -2
[    2.415761] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-15.ucode failed with error -2
[    2.415770] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-14.ucode failed with error -2
[    2.415779] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-13.ucode failed with error -2
[    2.415785] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-12.ucode failed with error -2
[    2.415787] iwlwifi 0000:01:00.0: request for firmware file 'iwlwifi-8000C-12.ucode' failed.
[    2.415790] iwlwifi 0000:01:00.0: no suitable firmware found!

lspci -nn | grep 8086

01:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)

The problem was a lot like what was found in this post so I followed these steps.

  • What is the Ubuntu version, kernel version? You need to install firmware. – Pilot6 Feb 2 '16 at 19:05
  • If you mean apt-get install linux-firmware-nonfree I just did that, but I still don't have a driver showing up configured under lshw -c network, or a wireless network – Al Christopher Feb 2 '16 at 22:38
  • Please answer the first question. It is nit about linux-firmware-nonfree, but about linux-firmware. You will need to update it depending on which verion is installed. – Pilot6 Feb 3 '16 at 4:42
  • Related: askubuntu.com/questions/729212/… – Pilot6 Feb 3 '16 at 17:13
  • Ubuntu 17-10, the drivers are extremely unstable but those are whats installed – Al Christopher Nov 11 '17 at 1:39
2

If you are using Ubuntu 14.04, you need to connect to internet by wire or a USB adapter and run in terminal:

sudo apt-get update
sudo apt-get install linux-generic-lts-wily linux-firmware

and reboot.

This will install kernel 4.2 that supports this adapter and will update the firmware.

1

Your system cannot find the firmware for your wireless adapter. apt-file search -x 'iwlwifi-8000C-.*\.ucode' returns:

linux-firmware: /lib/firmware/iwlwifi-8000C-13.ucode

The most likely solution to your issue seems to be to install that package, if you can find another method to connect your computer to the internet:

sudo apt-get install linux-firmware

Otherwise you can perform an offline installation.

Then you need to reload the wireless driver module or reboot the computer.

Edit: This only works on Trusty (with the trusty-updates repository enabled).

For Wily and the upcoming Xenial the adapter will work out-of the-box.

  • 1
    It depends on which Ubuntu version is installed. But OP does not tell us. I suspect OP has a non-ubuntu distro. – Pilot6 Feb 3 '16 at 8:44
  • As you're a reputation 1 user: if this answers your question, don't forget to click the grey ☑ under the "0" at the left of this text to accept it, which means "yes, this answer is valid"! – David Foerster Feb 3 '16 at 8:59
  • This won't work e.g. on 14.04. – Pilot6 Feb 3 '16 at 17:13
  • @Pilot6: I ran the command on 14.04.3. According to packages.ubuntu.com/… the file is included in trusty-updates. I'll make a note in my question about that. – David Foerster Feb 3 '16 at 18:41
  • Firstly OP does not have any internet connection. And 3.19 kernel will not load firmware 13 – Pilot6 Feb 3 '16 at 18:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.