3

I'm new to Ubuntu and Linux in general. I've just started using it for one of my college courses and instead of having all of us install Linux on our machines they had us install a virtual machine (not sure if that is what could be the issue or not). Anyways, as the title says I can not go about changing my preferences in gedit. Everytime I wish to edit a file with gedit or try to change the preferences I am met with this code:

(gedit:760): dconf-WARNING **: failed to commit changes to dconf: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code4: Failed to create file '/home/dev/.config/dconf/user.DAFJCY': No such file or directory

(gedit:760): dconf-WARNING **: failed to commit changes to dconf: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code4: Failed to create file '/home/dev/.config/dconf/user.YCYLCY': No such file or directory

(gedit:760): dconf-WARNING **: failed to commit changes to dconf: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code4: Failed to create file '/home/dev/.config/dconf/user.KGR6BY': No such file or directory

(gedit:760): dconf-WARNING **: failed to commit changes to dconf: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code4: Failed to create file '/home/dev/.config/dconf/user.PYA9BY': No such file or directory

(gedit:760): dconf-WARNING **: failed to commit changes to dconf: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code4: Failed to create file '/home/dev/.config/dconf/user.MV98BY': No such file or directory

I am still able to properly edit code and everything, but I get these warnings every time I run gedit. When I try to change preferences I am met with the same code, but only one of the warnings. I've also noticed that when I wish to change my terminal preferences they don't save the next time I open the terminal.

After looking into my .config file I noticed there is no dconf directory/file in there; there is only something labeled xfce4. Any help is appreciated and I can provide other information as necessary. Thank you.

2

I had the same problem (using Bash on Ubuntu on Windows, after the Windows 10 creators update), and it went away after I installed:

sudo apt-get install dconf-editor dbus-x11

See also, https://www.reddit.com/r/Windows10/comments/4rsmzp/bash_on_windows_getting_dbus_and_x_server_working/)

1

If you want to get rid of the warnings:

cd 
mkdir .config/dconf

Regarding saving preferences:

Before changing some preferences:

~/.config/dconf$ file user
user: GVariant Database file, version 0
rinzwind@schijfwereld:~/.config/dconf$ ls -l user
-rw-rw-r-- 1 rinzwind rinzwind 20023 mrt 13 09:20 user

After changing:

rinzwind@schijfwereld:~/.config/dconf$ ls -l user
-rw-rw-r-- 1 rinzwind rinzwind 20302 mrt 13 09:21 user

So it looks like that will be fixed too after adding the directory.

  • Unfortunately, I can't even make the directory in the first bit of code due to it not being allowed (this is for a course so there are a lot of restrictions). I appreciate your input though! – Cody Crofts Mar 18 '16 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.