0

I have an HP Zbook running Ubuntu-gnome 14.04.3 LTS x64. This machines comes with the nvidia K610m video card. Here is my issue: Leave the default BIOS setting to "Legacy" and install Ubuntu. Once complete, run "additional drivers" and change to the nvidia driver, restart the workstation. Everything works fine. Change the BIOS setting to UEFI-Native and install Ubuntu. Once complete, run "additional drivers" and change to the same nvidia driver, restart the workstation. No longer able to successfully boot the workstation. Boot process stops at Restoring Resolver State. The only solution is to hit CTRL-ALT-F3 and login at the console level and run "$ sudo apt-get remove nvidia-xxx" restart the workstation and it works again.

The issue is clearly with the UEFI setting and not the nvidia driver or the kernel - any thoughts on how to correct this?

  • Probably due to secure boot. Disable secure boot in your bios and try UEFI again. – Panther Feb 1 '16 at 22:01
  • No, it's nothing to do with Secure Boot; that would prevent the computer from booting. (With Fedora, Secure Boot can also prevent drivers from loading, but Ubuntu doesn't enforce that restriction.) It's a driver bug. EFI-mode and BIOS-mode boots sometimes initialize hardware somewhat differently, and if a driver isn't written to cope with both conditions, it will fail in one (usually EFI). It's conceivable that passing an extra kernel option will help, but I have no specific suggestions for what to try. – Rod Smith Feb 2 '16 at 1:03
  • i tried passing the acpi=off during the boot process and i get the same result. any other thoughts on which boot param i can pass during the boot process? – LCFUT Feb 2 '16 at 14:34
  • SecureBoot is an option but not selected – LCFUT Feb 2 '16 at 14:34
0

Solved - The HP Zbook 15 G2 has a "BIOS" setting under Advanced - Device Configuration - Hybrid Graphics which was set to "Auto" by default. Changing this setting to "Disabled" allows the nvidia-352 driver to be installed and functions properly.

0

Update:

Even though the above solution worked, changing the Hybrid Graphics Mode, Plymouth no longer would display properly.

Below are the 4 lines of code that will correct this issue as well:

sudo sed -i -r 's/#GRUB_GFXMODE=640x480/GRUB_GFXMODE=1024x768/' /etc/default/grub

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash

sudo update-grub2

sudo update-initramfs -u

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.