I was running Xubuntu 8.04 "Hardy Heron". I configure the vnc by adding vino-server to the autostarted app. I accessing the display only via VNC, so I removed the monitor and ir worked fine.

When I upgrade to 10.04 "Lucid Lynx", I was unable to connect. I borrow back the monitor and I plug it. I was seeing nothing so I do a restart by ssh. When it restart, I was able to vnc without an issue. I removed the monitor and worked like that for a few week, but when I installed some update, I needed to restart. After the restart, the vnc is not available. When I to a ps -aux by ssh, the xserver does not seem to be running.

How could I tell xubuntu 10.04 to automatically start the xserver when no monitor is plug, just as 8.04?



Replace xorg.conf in /etc/X11 by the file in : http://ubuntu-virginia.ubuntuforums.org/showpost.php?p=9565510&postcount=25

Edit /boot/grub/menu.lst to add " nomodeset" to the line beginning with "# kopt=", then run sudo update-grub. The # should stay at the beginning of the line. (see https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#Working%20around%20bugs%20in%20the%20new%20kernel%20video%20architecture)

Thanks to JanC for it's help. If I could, I would edit it's answer.


You might try the following solution: http://ubuntu-virginia.ubuntuforums.org/showpost.php?p=9565510&postcount=25

It might also be useful to use another driver instead of 'vesa' in the config (but OTOH, when used with VNC you have no real hardware acceleration anyway) or to change the resolution if you prefer that.

If you don't have an /etc/default/grub file, you're probably still using "legacy" grub (aka "grub 1"). In that case you will have to edit /boot/grub/menu.lst and change the line starting with "# defoptions=" to include nomodeset.

After adding nomodeset to any of those files, you should also run sudo update-grub (I see that's not mentioned in that forum post).

  • This solution is about "10.04 won't boot". In my case, it is booting, it's just not starting X. – Guillaume Coté Oct 15 '10 at 3:16
  • I don't have a file called /etc/default/grub – Guillaume Coté Oct 15 '10 at 3:21
  • I already have xorg.conf in /etc/X11, here what it contains : Section "Device" Identifier "Configured Video Device" EndSection Section "Monitor" Identifier "Configured Monitor" EndSection Section "Screen" Identifier "Default Screen" Monitor "Configured Monitor" Device "Configured Video Device" EndSection Section "ServerLayout" Identifier "Default Layout" Screen "Default Screen" EndSection – Guillaume Coté Oct 15 '10 at 3:30
  • @Guillaume: it's also about X not starting. And if you don't have that file, you're probably still using "legacy" grub (aka "grub 1"). In that case you will have to edit /boot/grub/menu.lst and change the line starting with "# defoptions=". – JanC Oct 15 '10 at 3:31
  • And you can edit the existing xorg.conf – JanC Oct 15 '10 at 3:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.