12

I use Evolution for mailing, and I like how new mail notifications appear in GNOME 3 notification area at the top of the screen. Unfortunately, it seems that Evolution must be running for this feature to work.

After googling a bit, I found there is a mail-notification-evolution package, but it uses message tray and I can't even install it in Ubuntu 15.10 with GNOME 3.18. Is there a better solution?

11

This worked for me on Gnome 15.04:

This is a How-To for making Email Notifications work for Gnome & Evolution (or any other mail client)

It all started when I decided that having Evolution open all the time was a bit annoying. I like Evolution because it integrates well with Google Mail, Contacts & Calendars, as well as all my IMAP mail boxes and my Yahoo POP mailbox. I didn't want to change client. I am using Mail Notification 5.4 by Jean-Yves Lefort in Ubuntu.

I could have minimised Evolution to the system tray and got mail notifications as they came in by using KDocker (KDocker tutorial) or AllTray but they didn't do quite what I wanted for one reason or another, for example, compatibility issues with Compiz.

Open Synaptic package Manager and search for "mail-notification", tick both mail-notification & mail-notification-evolution or in a terminal, type:

sudo apt-get install mail-notification mail-notification-evolution

Once this is done, open Evolution and check the plugin is installed and active: Edit > Plugins > Jean-Yves Lefort's Mail Notification (make sure there is a tick next to it).

Now you should find the configuration properties for mail notification - search the dash for "mail notification".

This is where you add your mailboxes, now, this is where things started going wrong and took a bit of working out. I added a mailbox by clicking 'Add', then on the option of 'Mailbox Type' I selected Evolution; of course, but it didn't work.

Trying to add Evolution in Mail notify gave me the error "Mail Notification can not contact Evolution. Make sure that Evolution is running and that the Evolution Jean-Yves Lefort's Mail Notification plugin is loaded." Both were true and so I tried to fix this problem, I read lots of bug reports and tried various 'fixes' all to no avail.

Then I thought to myself, why not take Evolution out of the equation until it's needed? So I configured my IMAP & POP accounts directly, OK, it took a bit longer but totally worth it, here's how...

  1. Select mailbox type (e.g. IMAP, POP, Gmail, etc)

  2. Fill in the General tab with mail server address, username/email address & password

  3. Click TAB called 'Connection' and select Authentication Mechanism.

    IMPORTANT

    I changed the drop down menu to Cram-MD5 for mine, but select whatever Authentication method your provider uses, if you don't know, trial and error only takes a few seconds more. If you leave it on 'Autodetect' you will get an error saying 'Unhandled IMAP or POP mailbox (unable to encode Base64: overflowed buffer)' and it won't work. if you have the wrong authentication Mechanism you'll get the same error or it won't connect, straight forward.

  4. Select the 'Details' Tab and changed the name of your mailbox if you want to, this is just what your Mailbox is identified as in the list, I called mine by the email address i.e. chris@blahblah.blah

  5. Apply,OK

    ...and thats it for that part.

    Now send yourself a test email to the address you just configured and you'll get a notification!

Mail Reader

If you right-click the mail icon, the first option is 'Mail Reader' and when you click it, what's supposed to happen is your Mail Reader (Evolution) opens up so you can read and reply to the email, mine didn't do anything.

The reason, I found out, was because it was trying to open Thunderbird... I found out by opening a terminal and typing:

tail -n 0 -f ~/.xsession-errors

Then clicking the 'Mail Reader' option. The output told me that the 'click' called Thunderbird.

To set the correct Mail Client, on the desktop taskbar, click open: System > Preferences > Preferred Applications

Under the Mail Reader section in the 'Command' box, type in Evolution, or the path to Evolution, i.e. /usr/bin/evolution

You might want to add options to it, you can check what options are available on the man page:

man evolution

Finally, close the Preferred Applications dialog and you're done, email notifications without Evolution being open.

4
  • Wow... Great answer from a new user! Nice to see all the info as well as the source. I edited to add the code formatting with ` characters and 4 spaces before lines of code. I also changed the bit about opening the application preferences. The interface has moved on a bit since 9.10, and the dash is now used to find things! Slightly tangential to the answer, but you might want to consider updating your computer to a newer version, to ensure security updates! I would recommend Ubuntu MATE as a nice one to go to - it has the old Gnome 2 interface with all the new features. Try it out! – Tim Feb 1 '16 at 20:48
  • @Nick Thank you very much. Alas, it is not possible to install mail-notification-evolution in Ubuntu 15.10 with GNOME 3.18 --- aptitude complains about unmet dependencies: mail-notification-evolution : Depends: evolution (< 3.17) but 3.18.2-0ubuntu1~wily1 is installed. – Dmitry Zotikov Feb 1 '16 at 21:01
  • @DmitryZotikov, have you tried this one : ubuntuupdates.org/package/core/wily/universe/base/… ? – Nick Feb 1 '16 at 21:38
  • @Nick, yes, I believe I can't install the package because I'm using GNOME version from staging ppa (Ubuntu ships with 3.16, mine is 3.18). – Dmitry Zotikov Feb 1 '16 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.