1

Attempting to mount an NFS share on my server and the following seems to be as far as I get... I've tried various solutions apart from an OS reload, which may be coming still... :) Not running an LDAP server, as each machine has it's own local authentication. Any suggestions would be appreciated.

-> sudo mount -t nfs -v 192.168.10.4:/Storage /home/david/Storage/

Reults in: mount.nfs: timeout set for Mon Feb 1 08:27:50 2016

mount.nfs: trying text-based options 'vers=4,addr=192.168.10.4,clientaddr=192.168.11.11'

mount.nfs: mount(2): Permission denied

mount.nfs: access denied by server while mounting 192.168.10.4:/Storage

  • 1
    What are the contents of your exports file on the server? What does showmount -e 192.168.10.4 say when run from the client? – steeldriver Feb 1 '16 at 17:04
0

If your showmount -e shows you the correct shares, you may have mapped UID/GID incorrectly.

From this how to page:

Note regarding UID/GID permissions on NFSv4 without Kerberos
    To make UID/GUD work as with NFSv3, set sec=sys both in the server's /etc/export and in the client's /etc/fstab. This will make

NFSv4 work with the old host-based security scheme.

    They do not work. Can someone please help investigating? Following this guide will result in UID/GID on the export being

generic despite having same UID on client and server. (According to my experience it works at least with "precise", if uid/gid are equal on both sides. hwehner) Mounting same share on NFSv3 works correctly with regards to UID/GID. Does this need Kerberos to work fully? According to http://arstechnica.com/civis/viewtopic.php?f=16&t=1128994 and http://opensolaris.org/jive/thread.jspa?threadID=68381 you need to use Kerberos for the mapping to have any effect.

    This is a possibly related bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=500778 

Not clear what is meant by UID/GID on the export being generic. This guide does not explicitly state that idmapd must also run on the client side, i.e. /etc/default/nfs-common needs the same settings as described in the server section. If idmapd is running the UID/GID are mapped correctly. Check with ps ax|grep rpc that rpc.idmapd is running.

I know that it's not clear but it's the only possible answer that I can give (as I'm also seeking the answer).

EDIT: As stated here, Kerberos isn't needed.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.