Vim 7.3 is out, but not available in the sources. Where can I get an installation package for the 7.3 version? I don't want to install it manually.

8 Answers 8


I couldn't find any official packages either, so I created a PPA. Feel free to use it:


apt-add-repository ppa:passy/vim
apt-get update
apt-get upgrade

Reference: How to use PPAs

  • 1
    Why can't I find your package when I search for "vim" on launchpad.net?
    – 1passenger
    Oct 14, 2010 at 20:30
  • 1
    Do you plan to keep it updated on occasion? Upstream is at version 7.3.028 now. Oct 15, 2010 at 0:18
  • 1
    Is this built with the same options used by the current vim package?
    – intuited
    Feb 6, 2011 at 19:13
  • 1
    Yes, it is. I did not change anything but the upstream package for building it.
    – passy
    Feb 9, 2011 at 22:22
  • 1
    Hm, the vim version in that PPA is now pretty ancient... Oct 10, 2012 at 11:43

I built vim from sources using this sequence of commands:

sudo apt-get build-dep vim-gnome
sudo apt-get install libssl-dev
mkdir -p ~/src
hg clone https://vim.googlecode.com/hg/ ~/src/vim
cd ~/src/vim
./configure --enable-multibyte --enable-pythoninterp --enable-cscope --enable-xim --with-features=big \
            --with-python-config-dir=/usr/lib/python2.7/config-$(dpkg-architecture -qDEB_HOST_MULTIARCH)

and I run it without installing by using this wrapper script ~/bin/vim:

if test -x $vimhome/src/vim; then
    VIMRUNTIME=$vimhome/runtime $vimhome/src/vim "$@"
    /usr/bin/vim "$@"

But I did that only because I couldn't find a PPA back then.

  • Nice solution, but I prefer the ppa way. :)
    – 1passenger
    Oct 15, 2010 at 7:58
  • Thanks for using the repo in your example; I was unaware of its existence. It doesn't feature very prominently (if at all) on vim.org.
    – intuited
    Feb 6, 2011 at 19:10
  • Updated the answer to work on Ubuntu 13.04 and newer, where you need to specify the Python config dir explicitly due to multiarch changes. Feb 19, 2014 at 15:18

Vimwiki now has some instructions for building and installing vim from source, for anyone else who finds this:

Here's the relevant text:

Building GUI Vim on Ubuntu

You need the required development packages on Ubuntu to build the GUI:

sudo apt-get install libncurses5-dev libgnome2-dev libgnomeui-dev  libgtk2.0-dev libatk1.0-dev libbonoboui2-dev libcairo2-dev libx11-dev libxpm-dev libxt-dev

Commands to build and install GUI Vim:

cd vim7
cd src
make distclean
./configure --with-features=huge --enable-gui=gnome2
sudo make install

Passy's PPA didn't work for me so I've installed vim packages from natty. The only thing you need besides the vim packages from natty are ruby1.8 and libruby1.8 debs.

Probably not the most genius of solutions, but it worked well for me.


The ppa worked for me, but I had to change my .vimrc:

" Stops vim from complaining about split lines using \
set nocp

" Fixes backspace not working to dedent a line
set backspace=indent,eol,start

After searching quite a few times I've come across a PPA with vim 7.3 built for 10.04, 10.10, 11.04 and 11.10. There are quite a few packages in there though, so have a look through the whole list in case another package will get upgraded and cause problems for you. If you wanted to just get the vim packages you could download them - here are the 10.04 links and this page gives the full list with expandable areas under each package showing the full list of links to individual packages.

The magic incantation is:

sudo apt-add-repository ppa:blueyed/ppa
sudo apt-get update
sudo apt-get upgrade

Reference: How to use PPAs


You could compile it from source in which you can always get the latest and greatest. You'll need to follow these steps: libncurses5-dev 1. sudo apt-get install build-essentials libncurses5-dev

  1. Get the latest from http://www.vim.org/download.php#unix

  2. Extract the compressed file to a directory with bunzip2.

  3. Enter the directory and type:

    A. ./configure B. make C. sudo make install D. sudo ln -s /usr/local/bin/vim /usr/bin/vim

Done. You now have the latest version of Vim on your system.

  • 4
    /usr/local/bin is already in Ubuntu's default path, and it appears before /usr/bin. I strongly discourage you from making that symlink in step D and cluttering /usr/bin with things not installed using apt/dpkg. Oct 15, 2010 at 0:25

Vim 7.3 is in the Ubuntu repositories from Ubuntu 11.04 onwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.