0

I have tried to install Kubuntu 15.10 and Ubuntu using the netinstaller, everything is working fine.

The problem is, KDE uses only one Theme, which is the GTK+ theme. Meaning I can't change them using the System settings. I checked environment variables. QT_OVERRIDE_STYLE (or whatever it's called) is not set. However systemsettings5 saves its changes to ~/.config/Trolltech.conf, but it looks like the changes aren't respected.

I have even tried to use the PPA with the "staging" version of Plasma. Unfortunately that doesn't work either. The problem also occurs on new users.

That's why I think it could have something to do with the default settings Ubuntu uses to make KDE apps look good on Unity.

0

I found a "solution". By default the environment variable QT_QPA_PLATFORMTHEME is being set to appmenu-qt5. Exporting kde instead fixes the problem if you try to start programs via Terminal.

However even adding this to .xinitrc or something else, this will just get overridden (probably by the plugin). Meaning the changes won't be permanent. Removing it (appmenu-qt5) via apt-get seems the only possible way to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.