13

I just installed ubuntu 11.10. I want to run an x-app from another system.

I updated ./xinit/xserverrc and removed the -nolisten option. I rebooted.

I can see that X is started with the nolisten option.

I don't have /etc/gdm subdir.

3
  • What purpose you need /etc/gdm dir? 11.10 uses LightDM instead of GDM thats way there is not such folder.
    – Guria
    Oct 27 '11 at 14:10
  • Note: "I want to run an x-app from another system." While I'm all in favor of modifying your nolisten parameter, for 99% of the use cases, simply ssh'ing to the remote host (possibly with the "-X" parameter, and definitely with "xauth" installed on the remote system) is by far the easiest way to fire up a remote X application. ssh even compresses the transaction, so you might see a slight speed boost.
    – user995746
    May 21 '13 at 18:15
  • I recommend using socat, as explained here: askubuntu.com/a/1360248/364151. The solution is not specific to a particular window manager or Ubuntu release.
    – Gogowitsch
    Aug 26 '21 at 15:19
20

You need to edit /etc/lightdm/lightdm.conf and add xserver-allow-tcp=true to it. Here's what mine looks like:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
xserver-allow-tcp=true

[XDMCPServer]
enabled=true

After that, run this:

sudo restart lightdm

If you have problems restarting, just 'ps ax | grep lightdm' and kill all the associated processes, then:

sudo start lightdm

I haven't researched yet, but I'm sure there are lots of configuration options for lightdm, I'm just not certain that they all work at the moment. But this one does. Here's what my X server process looks like now:

2981 tty7     Ss+    0:00 /usr/bin/X :1 -auth /var/run/lightdm/root/:1 vt7 -novtswitch
3

As of Ubuntu 16.04, it seems to be /usr/share/lightdm/lightdm.conf.d/100-custom.conf

and it wants to contain:

[SeatDefaults]
xserver-allow-tcp=true

[note another user felt the file could also be /etc/lightdm/lightdm.conf.d/100-custom.conf]

1
  • Worked for me on Xubuntu 19.10 with /etc/lightdm/lightdm.conf.d/100-custom.conf. Feb 4 '20 at 16:51
1

edit /usr/share/gdm/gdm.schemas, setting the key security/DisallowTCP to false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.