0

I am using ubuntustudio 14.04 (which is based on xubuntu) and trying to watch a movie with greek subtitles.

The subtitles do not appear correctly in any video player. But they do not appear correctly in a text editor either! (whether this is vi, a subtitle editor, geany, or gedit).

subs_image

Checking the languages, I had indeed installed support for greek language

lang_support

I realized that enabled languages must be placed above the "english" entry which is the fail safe language choice. But trying to drag "greek" above the "english" entry does not work. All other attempts DO work (for example dragging "english (Australia)", does work!).

What could be the problem here?

thank you in advance for your help!

Note: The above has nothing to do with typing in greek, which works fine in my case. Also the greek chars that I type through the keyboard appear fine on screen. Only the subtitles characters do not...

1

You can't place a non-English language after an English language. The simple rationale for this is that English is always available, so it would make little sense to set a non-English fallback language.

To enable Greek as the display language, you need to drag it to the far top of the list in this case.

  • please read my post thoroughly. dragging to the top is EXACTLY what I cannot do. – nass Feb 1 '16 at 11:52
  • @nass: You talk about dragging "greek" above the "english" entry, but I see that you already have both English (United Kingdom) and English (United States) above it. Consequently you need to drag the Greek entry above English (United Kingdom), i.e. to the very top of the list. – Gunnar Hjalmarsson Feb 1 '16 at 15:54
  • yes, and it does not work – nass Feb 1 '16 at 17:10
  • 1
    @nass: Please open a terminal window, and start Language Support from there using the command gnome-language-selector. Then try to drag Greek to the top, and if it fails again, let us know about any error message you see in the terminal window. – Gunnar Hjalmarsson Feb 1 '16 at 17:57
  • ok this time it made sense. dragging it ALL the way to the top, does move greek there. So no bug, in the sense that it is by design I cannot insert a language in the middle of a group of english* languages (or others). However, this is still not exactly suitable for me: the text files are read properly now, but I do not want the menus/etc to be in Greek.. I just do not want greek to be in the ignored part of the list – nass Feb 1 '16 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.