0

hello!

Ubuntu Trusty
PHP5, Apache2, mySQL installed

Download and unpack Wordpress to /var/www/html

Setup mySQL database and user for Wordpress, edit Wordpress config w/ correct info

In browser,

website.com/index.php is blank
website.com/readme.html works fine, points me to /wp-admin/install.php
webstie.com/wp-admin/install.php gives the classic error 
          "Error: PHP is not running"

Huh, this is strange. I purge and reinstall php5 and apache2, same error.

I create /var/www/html/info.php with

<?php
phpinfo();
?>

and it works fine, even tells me that mySQL is working

Okay, so in SSH I run

rm /var/www/html/index.php
nano ./index.php

and I copy the same code from info.php and the page is blank?

I am at the end of my abilities and patience with this issue, any help is appreciated. Thank you.

0

The output of phpinfo will include the path to the php.ini file currently in use. It contains all of PHP's settings.

Change this line in php.ini:

display_errors = off

to

display_errors = on

Then see if those "blank" pages give you an error message to work with.

0

Here is the tutorial that I followed and it works great so far it shows all the steps to configure all of the dependencies. What version of ubuntu are you using? ps: if php is not installed run sudo apt-get install php5 and WordPress requires php5-mysql package so run sudo apt-get install php5-mysql as well

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.