This question already has an answer here:

"The system network services are not compatible with this version" - ubuntu 14.04... I didn't even update anything thing.I have everything in network manager ....and I'm unable to connect to any network.. my system is dumb now without any network. I just tried to delete the previously connected networks from system-connections.. i tried the following code(I found it on askubuntu.com):

nmcli --fields UUID,TIMESTAMP-REAL con show | grep never | awk '{print $1}' | while read line; do nmcli con delete uuid $line; done

this link didn't solve my problem with the same title

Please help me and know that I'm not connected to a network.so help me in downloading external packages... and gracious!

none of the links on the askubuntu.com helped me! is there any possibility so I can download and reinstall some softwares!!!

enter image description here

marked as duplicate by Charles Green, kos, Eric Carvalho, Pilot6, Jacob Vlijm Feb 2 '16 at 19:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • confirming that this problem is still happening, many months after the OP. I keep my machine up-to-date and don't have pre-package releases selected in my update manager. Ugh. – zkurtz May 14 '16 at 14:49


Go to the above mentioned address and download three .deb files


this is for 64bit OS for 32bit use i386.deb

( please confirm your OS whether 32bit or 64bit)

Place them in a new folder on desktop and name the folder abc. Enter into it through terminal cd desktop abc and do "sudo dpkg -i filename.deb" for all the three. Restart the system, you will get the network tab and its details on the top to access.

I had the same problem yesterday after updating the system.
I tried this it worked.

  • Thank you very much and this really worked for me too...! – Sai Teja Nagamothu Feb 2 '16 at 18:30
  • I can confirm that it worked for me too. Thank you so much Prasad G R, it was really very frustrating to see this issue when I start my notebook despite that there was no any other installation than official software updates. – talha06 May 13 '16 at 6:18
  • Worked for me on 5/13/2016. Notice that it DOWNGRADES components, which makes me worried for the future. Still fixed for now. Massive relief! – Michael Durrant May 13 '16 at 10:50
  • Just used it and worked for me. I'm a bit scared too that this "old" solution could bring collateral bad effects – antonio.fornie May 17 '16 at 11:18

After a long research on this problem I'm deducting these possibilities:

Causes of the problem:

1) Incomplete installation. 2) Pre-released software might end up in causing so un-select it in software manager settings.

Solution : 1)Restart the network Manager. sudo service network-manager start

if this isn't work in your case download the following files manually from other pc and copy it to affected system. Click here to get those files. For 64 bit :

  1. libnl-3-200_3.2.21-1_amd64.deb
  2. libnl-route-3-200_3.2.21-1_amd64.deb
  3. libnl-genl-3-200_3.2.21-1_amd64.deb

For 32 bit: 1. libnl-3-200_3.2.21-1_i386.deb.deb
2. libnl-route-3-200_3.2.21-1_i386.deb.deb
3. libnl-genl-3-200_3.2.21-1_i386.deb.deb Put them in a folder and in terminal go up to that terminal,these are Debian files so install using this command.

sudo dpkg -i lib*.deb

this will install all three files at a time. And now restart your system. Every thing works fine!


I have the identical problem.. it occurred after an update in my case.. it no longer has the icon top right for wi-fi networks.. i suspect the wired NIC and wi-fi card ought to appear in the list (above picture) below Network Proxy but can't be sure.. never really looked there before i had a problem!

Not the answer you're looking for? Browse other questions tagged or ask your own question.