Sorry this is a little long. It's one of those issues that's a little tricky to describe.

I have two computers connected on a LAN. One is running Mythbuntu 11.10, and one is running Ubuntu 11.10 with (the awesome) Gnome Classic.

Before I upgraded to 11.10, I would often sit at Ubuntu machine and use SSH to access programs, such as Firefox, on the Mythbuntu machine. I could do this even if I already had a local instance of Firefox running.

So, just to be clear, before I upgraded I could run two separate instances of Firefox on one machine, each originating from a different machine. One local, and one over SSH from the other machine. One machine's Firefox has different bookmarks and settings than the other.

Now, after upgrading, if I have the local instance of Firefox running, and I try to run another over SSH, I don't get the instance from the other machine. I get a new window of the already running instance.

If I want to run a program from the second machine, I have to first close any instances from the first machine that might be already running.

This is true regardless of which machine's copy I opened first.

I don't know why this changed, but I suppose it doesn't matter. I'm just interested in results. How can I make it so that I can simultaneously run the two different machines' version of any one application at the same time? For example, two different Firefoxes originating from each machine?

  • How exactly do you run it "from another machine"? – Sergey Oct 27 '11 at 11:41
  • I was thinking about X forwarding disabled on the ssh daemon. But then you should get an error and not a local copy of the application. It might be worth checking /etc/ssh/sshd_config for X11Forwarding yes|no, though. – Mr Shunz Oct 27 '11 at 11:50
  • @Sergey: As I said, via SSH. Specifically, this command. ssh -X mythbuntu@ firefox So, if I have Firefox running on computer A, and then try to start Firefox using that command, I don't get Firefox from computer the computer at, I get another window of Firefox that is already running. – Questioner Oct 27 '11 at 11:51
  • @MrShunz: In that file I have X11Forwarding set to "yes". I tried setting it to "no", but that did not change anything. – Questioner Oct 27 '11 at 11:53
  • 1
    @DaveMG seems a firefox specific thing. I posted an answer. And X11Forwarding should definitively be set to yes. – Mr Shunz Oct 27 '11 at 11:55

Found this on ubuntu forums. Seems to be a firefox specific thing... BTW, proposed solution is executing firefox with the -no-remote option to force it not looking for an already running instance. Can't test it now but seems reasonable.

  • You are right. For some reason I had mistakenly thought it was more widely applicable, but actually it is just a Firefox issue. Adding this parameter has solved the problem. Thanks! – Questioner Oct 27 '11 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.