1

Hi this is my first post and have a problem. I have just updated today and found that when I try to shutdown a box comes on screen and it says

Received Error When Trying To Logout
Session Manager Must Be In Idle State
When Requesting Shutdown

I can shutdown By holding the power button down. I have a Dell Latitude 2100. Is there anyone who can help me with this I have not had much to do with Linux Ubuntu 14.04 I think it is. Thanks for reading this

  • Have you tried the init 0 command for shutdown? – SDsolar May 2 '17 at 20:20
0

If the desktop in question is xfce, check the following thread:

https://forum.xfce.org/viewtopic.php?id=6580

For me post 17 - delete the session file in

$HOME/.cache/sessions/xfce4-session-*

did the trick. The session file gets sometimes corrupted - once I was not able to login to XFCE - deleting the session file also solved that problem...

Note: Don't delete the session file. Just rename or move it. So in case the problem persists after XFCE created a new pristine session file you can go back to your old one.

  • I tried this , and it says " no such file " – L Lowther Feb 1 '16 at 1:25
  • to make sure you running XFCE, check output of echo $XDG_CURRENT_DESKTOP, should give you XFCE. Then check your users cache for XFCE session files: find ~/.cache -type f -name "xfce*session*" – hecke Feb 2 '16 at 10:35
-1

Try removing unity and then reinstalling unity via recovery mode.

sudo apt-get remove unity
sudo apt-get remove ubuntu-desktop
sudo apt-get install unity
sudo apt-get install ubuntu-desktop

Then click dpkg in recovery mode
Click on continue

Now try shutting down

  • I tride this and it says – L Lowther Feb 1 '16 at 1:27
  • I tried this and it says unable to locate package apt get unable to locate remove desktop unable to locate apt get unable to locate package install unable to locate apt get unable to locate package install – L Lowther Feb 1 '16 at 1:46
  • This problem occurs with xfce4. – James Bowery Sep 27 '16 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.