Having trouble getting any of the above to run. I've tried various upgrade and reinstall suggestions from other forums but with no luck. Software updater claims everything is up to date, but I can't open the settings from there either.

When i try to manually start the software-properties-gtk in terminal i get:

Traceback (most recent call last):   File "/usr/bin/software-properties-gtk", line 101, in <module>
    app = SoftwarePropertiesGtk(datadir=options.data_dir, options=options, file=file)   File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 98, in __init__
    SoftwareProperties.__init__(self, options=options, datadir=datadir)   File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
    self.reload_sourceslist()   File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)       File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 89, in get_sources
    (self.id, self.codename)) aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Ubuntu/n/a

It's worth pointing out that I can still install/remove software using apt-get or the software center.

Any suggestions? Thanks in advance for any help.



It seems to be a problem with your software sources. Press Alt+f2 on your keyboard and write following code


Then in the Ubuntu Software tab change the Download from setting. Change to Main Server if using any local server. See if it works.

If the above answer doesn't solve the error, open a terminal and run following code

sudo apt-get install software-properties-common

It should solve the error.

Another option is to update /etc/lsb-release file according to your installation, for example

    DISTRIB_DESCRIPTION="Ubuntu 14.04"
  • thanks for your reply, however running software-properties-gtk from the alt-f2 prompt doesn't seem to do anything. I suspect the same error is happening, just that there isn't any feedback like there is in the terminal? According to the terminal, software-properties-terminal is already up to date, i've tried removing then reinstalling it but with no luck. – biglam Jan 30 '16 at 14:44
  • I should add, the icon for software proerties does appear in the search, but the window doesn't open, so i'm not able to seee any tabs etc – biglam Jan 30 '16 at 14:45
  • Check the third option – Tanmay Jan 30 '16 at 15:01
  • that was it! /etc/lsb-release wasn't there! copied a backup file to it and it fixed everything instantly. Thanks very much! – biglam Jan 30 '16 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.