I am running 14.04 LTS on a Dell XPS 13 9343. Today I did a routine update through Software Updater and restarted when it prompted me. When I logged back in I had no internet connection and no icon in the menu bar to edit connections. When I open "Network" within the main Settings menu, I get the message:

The system network services are not compatible with this version

When I open the "Network Connections" dialog, all options are greyed out. I have attempted to connect to Ethernet as well as WiFi to no avail.

Please help, I am freaking out. This is the machine I use for my job and doing a fresh install of Ubuntu would be a massive hassle as I have all kinds of specialized software packages installed.

I should also mention that I tried reinstalling network-manager. I even removed and purged it, then reinstalled from the package provided on the Ubuntu website. That didn't change anything. I also purged and reinstalled the network-manager-gnome package to see if I could fix the GUI issues (nm-applet not working) but that didn't do anything either.

marked as duplicate by Fabby, Jacob Vlijm, kos, Pilot6, Eric Carvalho Jan 31 '16 at 18:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • A similar issue has been reported here. – usmanayubsh Jan 30 '16 at 9:30
  • I solved this problem like explained AnotherVictim. But for the future you should block version of this packages or disable "proposed" upgrade. – Luigi Roggio Jan 30 '16 at 17:49

I could recover from the same problem by downgrading to the following packages (assuming the 64-bit version):

  1. libnl-3-200_3.2.21-1_amd64.deb
  2. libnl-genl-3-200_3.2.21-1_amd64.deb
  3. libnl-route-3-200_3.2.21-1_amd64.deb

From a device with internet access download the above packages (e.g from packages.ubuntu.com) and find a way to transfer them to your computer. Install them with

    dpkg -i *.deb

After a reboot everything should work again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.