2

I'm using Ubuntu 14.04 and trying to connect to another machine (Windows 10) in a different network using remote desktop via RDP Protocol.

But when I try to connect I get this error message:

Unable to connect to RDP server 192.169.x.x

I already have "RDP" under Security option in Advanced Tab.

I understand I have to delete it but I cannot find this file (~/.freerdp/known_hosts) anywhere.

Reply:

Which machine an OS is the RDP server and which one is the client?

The RDP server is the Windows 10 machine and the client is the Ubuntu 14 machine.

Is the server machine reachable over the network (e. g. with ping)?

When I ping I get the following message:

Trying 192.168.x.x... 
telnet: Unable to connect to remote host: Connection timed out

Is the RDP port reachable (test with telnet [HOST] 3389)?

When I ping I get the following message:

Trying 192.168.x.x... 
telnet: Unable to connect to remote host: Connection timed out

Can other clients connect to the RDP server successfully?

I don't have other client options to try.

4
  • Which machine an OS is the RDP server and which one is the client? Is the server machine reachable over the network (e. g. with ping)? Is the RDP port reachable (test with telnet [HOST] 3389)? Can other clients connect to the RDP server successfully? Jan 30, 2016 at 10:06
  • Please edit your question, when you want to add information. Overall it's best to have everything relevant in one place. Also, comments may be deleted for various reasons. Jan 31, 2016 at 22:56
  • You need to setup Windows 10 firewall, opening the private network
    – user519497
    Mar 16, 2016 at 16:42
  • How is the firewall on the target machine set up? Is RDP enabled?
    – vidarlo
    Oct 23, 2017 at 13:39

2 Answers 2

1
nano ~/ .freerdp/known_hosts

That is the correct path. Notice the space. I was having the same problem with Remmina using RDP. First delete the entries from this file, then try reconnecting with Remmina. It should ask you to accept certificates.

1
  • In case you want to use this, make sure you make a back up from the file Jan 17, 2017 at 17:44
0

You said on a different network. Did you remember to VPN to the network before connecting? Plus, are you using the fully qualified domain name of the computer as opposed to its IP address in the "server" field? Also, make sure the Windows machine has network discovery enabled.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .