I have seen relevant solutions in askubuntu and other sites but none worked for me so far.

I reinstalled network manager, modem manager, tried to upgrade them and manually install everything, also tried nm-applet solution. But nothing seems to be working. The network manager icon is not there and normal reboot has no networking option. I have also gone to recovery and enabled networking via Ethernet and then resumed normal boot. But again after reboot there is not networking option. No WiFi, no Ethernet.

Can someone please help me out? Reinstalling will definitely solve this but all my settings and work will be gone and it is painful to set up again. So folks here please suggest me what to do.

  • What's the the output of lsb_release -a, uname -rm and apt-cache policy network-manager? – David Foerster Jan 30 '16 at 9:13
  • If you upgraded libnl packages recently, maybe you can try this. – Shiny Jan 30 '16 at 13:10

Get onto a working machine (or plug into internet using an Ethernet cable) and download these three packages ... they are the working versions prior to recent broken release :

wget http://mirrors.kernel.org/ubuntu/pool/main/libn/libnl3/libnl-3-200_3.2.21-1_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/main/libn/libnl3/libnl-route-3-200_3.2.21-1_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/main/libn/libnl3/libnl-genl-3-200_3.2.21-1_amd64.deb

once downloaded copy onto a memory stick or similar then transfer onto your broken ubuntu box ... then install :

sudo dpkg -i libnl-3-200_3.2.21-1_amd64.deb
sudo dpkg -i libnl-genl-3-200_3.2.21-1_amd64.deb
sudo dpkg -i libnl-route-3-200_3.2.21-1_amd64.deb

reboot and your Wifi will be back working ... enjoy

  • I had reinstalled OS. But thanks for your sincere assistance – ninja.stop Feb 12 '16 at 18:50
  • You are awesome :) – MasterMind May 14 '16 at 10:57
  • 1
    Thank you sir!The same solution worked for me under 14.04 for Ethernet connection. The latest update from Ubuntu broke the network manager. – lv10 May 14 '16 at 14:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.