0

I have been using Ubuntu from time to time but not an expert. I have been looking for a fix to this problem to no avail. The Ubuntu Software Center was working fine and now suddenly it is not starting up. Initially I thought it had something to do with installing the Synaptic package manager so I removed it and tried reinstalling software center as mentioned in this question. It did not work.

Trying to run software-center in terminal yielded the following:

2016-01-30 12:36:02,351 - softwarecenter.backend.zeitgeist_logger - WARNING - Support for Zeitgeist disabled
2016-01-30 12:36:02,415 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2016-01-30 12:36:02,474 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/dbus/proxies.py', 410, '_introspect_error_handler')'
2016-01-30 12:36:02,474 - dbus.proxies - ERROR - Introspect error on com.ubuntu.sso:/com/ubuntu/sso/credentials: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process com.ubuntu.sso exited with status 1
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 338, in __init__
    self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/appmanager.py", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 141, in find_oauth_token_sync
    sso.find_credentials()
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 74, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process com.ubuntu.sso exited with status 1
0

Apparently it was a problem with the symbolic link. An answer provided here helped.

$ cd /usr/local/lib/python2.7/dist-packages/zope
$ ln -s /usr/lib/python2.7/dist-packages/zope/interface

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.