0

I have a HP 15-ac149tx notebook with ubuntu 14.04 intalled and i am facing problem with the wifi . At first it didnt work then i tried this

sudo add-apt-repository ppa:hanipouspilot/rtlwifi

sudo apt-get update

sudo apt-get install rtlwifi-new-dkms linux-firmware

It worked but i am getting very weak connection like i have to sit next to the router to get the connection that to one bar out of three.

How can i increase the connection ? Do i need any usb wireless adapter for this issue ? If so please let me know which one to buy that works on ubuntu 14.04 .

0

Looks like your problem is hardware related. Your wifi device has two antennas and until now, the linux driver was not capable to use the correct antenna per default.

Looks like a new driver is available now, where you can switch between the two antennas.

The repository owner posted a howto... (First I would uninstall the driver and firmware you installed and remove the ppa again)

tutorial by 'lwfinger'

Check this link: https://github.com/lwfinger/rtlwifi_new/issues/28

git clone git://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
git checkout rock.new_btcoex
make
sudo make install

Reboot. After the system comes up:

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=1

Now test. If that still does not work, then try

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2

One or the other should work. Once you know, then add that ant_sel part to the options when rtl8723be is loaded.

  • There is no need to install a driver from lwfinger since the same driver is installed from my repo in dkms format. ant_sel may really help. – Pilot6 Jan 29 '16 at 21:17
  • So in that case, he would just create a file /etc/modprobe.d/rtlwifi-new with the content 'options rtl8723be ant_sel=1' (or ant_sel=2), right? Hope he reads the comments first... ;) – minimec Jan 29 '16 at 21:31
  • I think so. I just pack that driver to launchpad in dkms format to hanipouspilot. Maybe I need to update the ppa to a new branch. I will look into it. – Pilot6 Jan 29 '16 at 21:34
  • Still need help guys i did all of the above procedures still nothing . Can anybody help me ? ps : i get the two ant_sel system but it seems to doing nothing . – Pradhvan Bisht Jan 29 '16 at 23:47
  • Post modinfo -p rtl8723be – Jeremy31 Jan 30 '16 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.