0

I'm really confused. I'm trying to install rvm ( Ruby's version manager ) but keep getting an error message. Something about how /etc/pki/tls/certs/ca-bundle.crt not found. I believe the security certificates are located in /etc/ssl/.... on Ubuntu. So I tried something like

ln -s /etc/ssl/certs/ca-certificates.crt /etc/pki/tls/certs/ca-bundle.crt

but that did not work. I get an error message that I'm not able to create that symbolic link. Could someone explain how I can do that? I also tried to compile (from source) Ruby 2.3. It worked and most of the Ruby files work just fine, but when I enter

require "openssl"

I get an error message that the file is not available. I suspect the same problem is happening and I'll have to recompile Ruby so that it "knows" that my security certificates are in /etc/ssl/certs/ and NOT in /etc/pki/tls/certs/.

  • 2
    did you try to create the link using sudo? – Wayne_Yux Jan 29 '16 at 16:15
1

Most likely you will need to be root to do something in /etc/....

Try

sudo ln -s /etc/ssl/certs/ca-certificates.crt /etc/pki/tls/certs/ca-bundle.crt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.