I want to dual boot ubuntu 15.10 with already installed windows 10 (upgraded from 8). From what I've been researching, in order for ubtuntu to be dualbooted with windows 10 on a uefi machine, the ubuntu installation media (in this case a usb) must also be booted from uefi (as opposed to changing the boot setting to Legacy and booting from usb that way), so that the correct grub-efi, instead of grub-pc, is installed.

I have a Dell Inspiron 7000 series with core i7 processor its 64bit and also boots windows with uefi. This dell does not seem to support booting a usb from uefi as no matter what I try, "Boot from usb" will NOT appear under "UEFI boot options." The only way for me to boot from the usb is to boot in legacy mode and then select boot from usb. The problem is, when I try to install ubuntu this way, after rebooting, my system boots directly to windows 10 and the grub option does not even appear, let alone the actual bootloader screen to select which OS I want to boot. I assume my problem is that I can not install ubuntu correctly since I have to boot the usb in legacy mode when trying to install.

Also, the filesystem on the usb appears as FAT32 which should be recognizable to windows to support usb uefi booting

Does anyone know of a way I can "Boot from USB" with "UEFI boot option"?

I was following the steps on https://help.ubuntu.com/community/UEFI but under General Principles, number 5, I can not do this with my system. Can anyone help me with a workaround or anything?

  • 1
    In the UEFI setup, under boot, look for Add boot entry, select the USB drive, the EFI folder, then one of the EFI boot files. Jan 29, 2016 at 2:42
  • Thanks for your comment, Im currently trying a reinstall with installing the bootloader to the efi partition that windows uses. If (probably when) this fails, I will try what you have suggested
    – wvu_evan12
    Jan 29, 2016 at 3:00
  • 1
    I tried what you suggested and when selecting the efi file there are two, BOOTx64.EFI and grubx64.efi. When boot both of those options, they both take me to the grub command line and nothing else. What can I do?
    – wvu_evan12
    Jan 29, 2016 at 3:20
  • 1
    Do you have a grub.cfg file in /EFI/ubuntu for grub to use? The full one from your installed system (/boot/grub/grub.cfg) would work, but better to use the installer's stub to bring in that one, since it is the one maintained.
    – ubfan1
    Jan 29, 2016 at 6:07
  • Possible duplicate of this question: askubuntu.com/questions/374931/… .
    – ipse lute
    May 24, 2016 at 12:27

2 Answers 2


I've had the same issue for 1 year now on my Inspiron 5567 Kaby Lake 7500U.

The secret to install Ubuntu/Debian/any linux distrib on new Inspiron 5567 Kaby Lake is here: you need to create a special boot setup.

For a dual boot with a Windows 10 preinstalled :

  1. Burn your iso with Rufus (mostly GPT mode for laptop after 2013, config autoselected by default in Rufus. Change to MBR if the pc is older),
  2. Go in your USB key and enter the EFI and please notice the name of the files here...as grubx64.efi (unsecure boot) or shimx64.efi (secure boot). You will need this info later.
  3. Restart the PC with the USB plugged in. When the Dell logo appears, hit F12 till you see the boot menu. If you can see your USB key here, don't select it. First, enter the BIOS by selecting bios setup.
  4. Go on Boot Sequence, you need to ensure the BIOS is set to UEFI, disable Legacy option ROMS and check that secure boot is enabled on the Secure Boot Enable line.
  5. Now the most important operation... come back to Boot Sequence (General menu on the left)

    • click on Add Boot Option. The Add Boot Option window will pop up. Type a name in the Boot Option Name text area ("Ubuntu", for example).
    • Click the button to the left of the File Name text area. The EFI Boot Selection window will pop up.
    • In the File System drop down menu choose FS0: and EFI. Then using the directories section, navigate until you can choose SHIMx64.EFI (for Ubuntu only - for other distros use grubx64.efi or grubx.efi if your PC is not amd64, anyway it will be named grubxxxxx.efi) in the Files section.
  6. A new boot option will now appear on the top and in the boot menu. Save and exit

  7. The pc will now restart, when the Dell logo is coming, press F12 again, till the boot menu appears. Select the name you entered in the previous step (NOT the USB key)

  8. The GUI installer will come up and you can run it

If it does not work for you exactly like this, try disabling secure boot in the BIOS.

  • you made my day. I updated the BIOS of my Optiplex (after meltdown and spectre) which overwrote the original setting and ubuntu was gone from the menu. Cheers!
    – Philippe
    Jan 10, 2018 at 19:26
  • 1
    You are a hero! It worked but with secure boot disabled!
    – Yahya
    Sep 29, 2020 at 14:24
  • 1
    I am trying to do this on Dell laptop, and I don't see SHIMx64 option, there is grubx64 option. Jul 2, 2021 at 11:05
  • @RahulSagore same here (well Dell desktop). I used `grubx64' and it worked fine. Note: my secure boot is disabled Oct 12, 2021 at 7:46

You don't say what tool you used to create your USB drive. This is a critical detail because not all boot programs are created equal. Rufus and Unetbootin usually work well for creating EFI-bootable media, but this varies somewhat from one computer to another, so even if you used one of those you might try something else.

Another option is to install in BIOS/CSM/legacy mode and then install my rEFInd boot manager from Windows. This will require that Secure Boot be disabled, but once rEFInd is up and running, it should enable you to boot Ubuntu.

  • Hi... maybe you did not read as you should :)) "For a dual boot with a Windows 10 preinstalled : Burn your iso with Rufus (mostly GPT mode for laptop after 2013, config autoselected by default in Rufus. Change to MBR if the pc is older),..."
    – jycemea
    Feb 20, 2019 at 13:36
  • @jycemea, the sentence you quoted is from an answer, not the question; and it was posted AFTER my answer.
    – Rod Smith
    Feb 22, 2019 at 5:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.