2

I tried to install haskell-platform and I am getting the following unmet dependencies.


Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies: haskell-platform : Depends: ghc (>= 7.6.3) but it is not going to be installed Depends: ghc (< 7.6.3+) but it is not going to be installed Depends: libghc-async-dev (>= 2.0.1.4) but it is not going to be installed Depends: libghc-async-dev (< 2.0.1.4+) but it is not going to be installed Depends: libghc-attoparsec-dev (>= 0.10.4.0) but it is not going to be installed Depends: libghc-attoparsec-dev (< 0.10.4.0+) but it is not going to be installed Depends: libghc-case-insensitive-dev (>= 1.0.0.1) but it is not going to be installed Depends: libghc-case-insensitive-dev (< 1.1.0.2+) but it is not going to be installed Depends: libghc-cgi-dev (>= 3001.1.8.3) but it is not going to be installed Depends: libghc-cgi-dev (< 3001.1.8.3+) but it is not going to be installed Depends: libghc-fgl-dev (>= 5.4.2.4) but it is not going to be installed Depends: libghc-fgl-dev (< 5.4.2.4+) but it is not going to be installed Depends: libghc-gluraw-dev (>= 1.3.0.0) but it is not going to be installed Depends: libghc-gluraw-dev (< 1.3.0.0+) but it is not going to be installed Depends: libghc-glut-dev (>= 2.4.0.0) but it is not going to be installed Depends: libghc-glut-dev (< 2.4.0.0+) but it is not going to be installed Depends: libghc-hashable-dev (>= 1.2.1.0) but it is not going to be installed Depends: libghc-hashable-dev (< 1.2.1.0+) but it is not going to be installed Depends: libghc-haskell-src-dev (>= 1.0.1.5) but it is not going to be installed Depends: libghc-haskell-src-dev (< 1.0.1.5+) but it is not going to be installed Depends: libghc-html-dev (>= 1.0.1.2) but it is not going to be installed Depends: libghc-html-dev (< 1.0.1.2+) but it is not going to be installed Depends: libghc-http-dev (>= 1:4000.2.8) but it is not going to be installed Depends: libghc-http-dev (< 1:4000.2.8+) but it is not going to be installed Depends: libghc-hunit-dev (>= 1.2.5.2) but it is not going to be installed Depends: libghc-hunit-dev (< 1.2.5.2+) but it is not going to be installed Depends: libghc-mtl-dev (>= 2.1.2) but it is not going to be installed Depends: libghc-mtl-dev (< 2.1.2+) but it is not going to be installed Depends: libghc-network-dev (>= 2.4.1.2) but it is not going to be installed Depends: libghc-network-dev (< 2.4.1.2+) but it is not going to be installed Depends: libghc-opengl-dev (>= 2.8.0.0) but it is not going to be installed Depends: libghc-opengl-dev (< 2.8.0.0+) but it is not going to be installed Depends: libghc-parallel-dev (>= 3.2.0.3) but it is not going to be installed Depends: libghc-parallel-dev (< 3.2.0.3+) but it is not going to be installed Depends: libghc-parsec3-dev (>= 3.1.3) but it is not going to be installed Depends: libghc-parsec3-dev (< 3.1.3+) but it is not going to be installed Depends: libghc-primitive-dev (>= 0.5.0.1) but it is not going to be installed Depends: libghc-primitive-dev (< 0.5.0.1+) but it is not going to be installed Depends: libghc-quickcheck2-dev (>= 2.6) but it is not going to be installed Depends: libghc-quickcheck2-dev (< 2.6+) but it is not going to be installed Depends: libghc-regex-base-dev (>= 0.93.2) but it is not going to be installed Depends: libghc-regex-base-dev (< 0.93.2+) but it is not going to be installed Depends: libghc-regex-compat-dev (>= 0.95.1) but it is not going to be installed Depends: libghc-regex-compat-dev (< 0.95.1+) but it is not going to be installed Depends: libghc-regex-posix-dev (>= 0.95.2) but it is not going to be installed Depends: libghc-regex-posix-dev (< 0.95.2+) but it is not going to be installed Depends: libghc-split-dev (>= 0.2.2) but it is not going to be installed Depends: libghc-split-dev (< 0.2.2+) but it is not going to be installed Depends: libghc-stm-dev (>= 2.4.2) but it is not going to be installed Depends: libghc-stm-dev (< 2.4.2+) but it is not going to be installed Depends: libghc-syb-dev (>= 0.4.0) but it is not going to be installed Depends: libghc-syb-dev (< 0.4.0+) but it is not going to be installed Depends: libghc-text-dev (>= 0.11.3.1) but it is not going to be installed Depends: libghc-text-dev (< 0.11.3.1+) but it is not going to be installed Depends: libghc-transformers-dev (>= 0.3.0.0) but it is not going to be installed Depends: libghc-transformers-dev (< 0.3.0.0+) but it is not going to be installed Depends: libghc-unordered-containers-dev (>= 0.2.3.0) but it is not going to be installed Depends: libghc-unordered-containers-dev (< 0.2.3.0+) but it is not going to be installed Depends: libghc-vector-dev (>= 0.10.0.1) but it is not going to be installed Depends: libghc-vector-dev (< 0.10.0.1+) but it is not going to be installed Depends: libghc-xhtml-dev (>= 3000.2.1) but it is not going to be installed Depends: libghc-xhtml-dev (< 3000.2.1+) but it is not going to be installed Depends: libghc-zlib-dev (>= 0.5.4.1) but it is not going to be installed Depends: libghc-zlib-dev (< 0.5.4.1+) but it is not going to be installed Depends: ghc-haddock but it is not going to be installed

These dependencies are different from the other questions, here and here , on this site.

Some packages mentioned in the first question are also the ones I have come across so I implemented the solution there. However I couldn't get it to work (the same dependencies kept coming up).

Leaving it aside for a moment I tried installing the haskell stack. However it requires me to install the package libgmp3-dev. I cannot seem to be able to install it using synaptic or sudo apt-get install.

I am looking for any suggestions to installing haskell-platform or failing that ghc compiler on my system. I am running Ubuntu 14.04.

Please feel free to edit my question or request any information. Thank you in advance for your time.

7
  • Can't you download the packages and installed them through dpkg -i ? – LnxSlck Jan 28 '16 at 22:54
  • @LnxSlck No, it gives me "Errors were encountered while processing:" – DBS Jan 28 '16 at 22:58
  • Can you post the errors? – LnxSlck Jan 28 '16 at 23:13
  • here is the dialogue: sudo dpkg -i libgmp3-dev I get <p> dpkg: error processing archive libgmp3-dev (--install): <br> cannot access archive: No such file or directory<br> Errors were encountered while processing:<br> libgmp3-dev </p> – DBS Jan 28 '16 at 23:34
  • Please don't post screenshots of text. Just copy the text and apply code formatting. – muru Jan 28 '16 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.