21

I created a new profile that opened with the fortune program (atp-get install fortune-mod for the download location) and set it as the profile with which to open all new terminals with so that I would get a new fortune when I opened terminal. Unfortunately I didn't know to set "exit terminal when process exits" to something else so that it wouldn't exit out almost immediately. Currently it does exit as soon as fortune exits which is nearly immediately and I need to delete the profile but i cant through the terminal "manage profiles" option because it exits too quickly to even try and open the edit menu let alone delete the profile. I need to know what directory the profile is saved to so that i can delete is manually. I tried to do a system wide search but the results of that search was tons of files and folders and I don't have time to open them all. I appreciate all help i can get. Thanks in advance.

2
  • 2
    How to import gnome-terminal profile from dconf database: unix.stackexchange.com/a/199864 Oct 8, 2016 at 16:51
  • 1
    As a note, the comment/link from @bartolo-otrit refers to gnome-terminal profiles in dconf (note D) - but in ubuntu 14, gnome-terminal profiles are in gconf (note G); and for gconf, you can look into ~/.gconf/apps/gnome-terminal/ for the profiles
    – sdbbs
    Feb 20, 2017 at 8:10

2 Answers 2

18

Profiles for GNOME Terminal are stored in the GConf configuration system. To modify them directly, press Alt+F2 to display the "Run a command" box, enter gconf-editor, and then browse to /apps/gnome-terminal/profiles.

Unchecking /apps/gnome-terminal/profiles/Default/use_custom_command should solve your problem.

An alternative method for getting out of this situation is to override the custom command by specifying another as a command-line argument, e.g. gnome-terminal -x bash, once again in the "Run a command" box.

6
  • 1
    The alternative method ended up being the one that worked. Thank you very much. I'd vote up but I don't have 15 reputation :( Nov 3, 2011 at 4:17
  • The alternative command is also the only one that worked. In the gconf-editor, there wasn't any "use_custom_command checkbox.
    – Balinus
    Aug 19, 2016 at 14:53
  • @ændrük sorry for taking so long to accept. I just got a notification for this question which brought me back all these years later. Oct 10, 2016 at 17:38
  • 4
    On Ubuntu 17.04, these entries aren't there in gconf-editor
    – phant0m
    May 24, 2017 at 0:40
  • 1
    Profiles for # GNOME Terminal 3.32.1 are stored in dconf not gconf A comment on this question seems to imply that they should be migrated over automatically to dconf, but I haven't got that to work askubuntu.com/questions/906137/…
    – EoghanM
    Aug 14, 2019 at 11:00
5

You can also run xterm, another terminal emulator that is available in Ubuntu. From there you can run any commands you need.

To make it the default terminal, run:

sudo update-alternatives --config x-terminal-emulator

And change the default to whatever you want.

Another approach to fix Gnome Terminal is to use Nautilus (the file manager) to delete all custom preferences:

  • Navigate to ~/.gconf/apps/gnome-terminal (it's a hidden folder, hit CTRL+H to view)
  • Edit the xml files there, or simply delete the whole gnome-terminal folder
  • Open your Gnome Terminal again, it will be restored with factory settings
4
  • +1 for having indicated the path to the configuration files Nov 5, 2021 at 18:43
  • @XavierStuvw: please note that since then Gnome Terminal switched from GConf to DConf, so those paths are not valid anymore since at least Ubuntu 18.04+
    – MestreLion
    Nov 6, 2021 at 19:04
  • I am on Ubuntu 20.04 and can find precisely ~/.gconf/apps/gnome-terminal. Perhaps because I use Unity as desktop manager? Nov 6, 2021 at 21:10
  • @XavierStuvw: Maybe that is a leftover from previous installs. Have you upgraded to 20.04 from, say, 14.04 or 16.04? I'm am sure Gnome Terminal does not use that path anymore in 18.04, and I still use Unity DE too. You might test and create/edit some terminal profiles and see if those changes are actually saved there. They probably won't.
    – MestreLion
    Nov 7, 2021 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.