5

Super (aka the Windows-Logo key) doesn't work as my base Unity Dash/Launcher keyboard shortcut.

Setting it in ccsm (sudo apt-get install compizconfig-settings-manager) by going to ...

Desktop->Ubuntu Unity Plugin->Launcher->Key to show the Dash, Launcher, and Help Overlay

... doesn't work. ccsm immediately sets-then-unsets it.

As in, if I set the launcher shortcut to, oh, <Super><Alt> (or anything else) it works fine, but if I set it to only <Super>, it immediately unsets itself after I hit OK.

I'm not sure where to go from here.

1 Answer 1

7

I figured it out. I think it's a bug in ccsm.

I used dconf to watch the settings change while using ccsm:

$ dconf watch /
/org/compiz/profiles/unity/plugins/unityshell/show-launcher 
   unset

unset??

$ dconf read /org/compiz/profiles/unity/plugins/unityshell/show-launcher
$

Yep... The key doesn't even exist.

$ dconf list /org/compiz/profiles/unity/plugins/unityshell/
[... show-launcher not in list...]

So then I manually set it also using dconf (NOTE you have to double- AND single-quote the value string):

$ dconf write /org/compiz/profiles/unity/plugins/unityshell/show-launcher "'<Super>'"

$ dconf read /org/compiz/profiles/unity/plugins/unityshell/show-launcher
'<Super>'

Now everything works. Yay!

EDIT: For DELL owners: @jooon figured out a different solution. Dell installs a package that intentionally breaks the super key called dell-super-key.

2
  • I had the same problem and this solved it. However, the root cause for me was because I have a default dell installed ubuntu with the package dell-super-key that disables this dconf setting. See this answer askubuntu.com/a/752102/300383
    – jooon
    Jan 3, 2017 at 10:23
  • Oh wow, yeah. I have a Dell too. Why would they do that....... Jan 3, 2017 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.