5

I followed this guide to create a hotspot:

Create WiFi hotspot on ubuntu

I go through all the steps but when it comes to the end, connecting my laptop to the hotspot, it does not work.

I have tried connecting to a hidden WiFi network but this also does not connect.

Can anyone help?

$ lsb_release -a
    Distributor ID: Ubuntu
    Description:    Ubuntu 15.04
    Release:    15.04
    Codename:   vivid

$ uname -a
Linux mylinux 3.19.0-28-generic #30-Ubuntu SMP Mon Aug 31 15:52:51 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

/etc/NetworkManager/system-connections$ sudo cat android-wifi 
[connection]
id=android-wifi
uuid=af9a2d23-c1e4-409d-a80e-d8c8271ba291
type=wifi

[wifi]
ssid=android-wifi
mode=ap
mac-address=A0:A8:CD:6F:0C:34

[wifi-security]
key-mgmt=wpa-psk
psk-flags=1

[ipv4]
method=shared

[ipv6]
method=auto
ip6-privacy=0
2

I found the answer.

After following the guide and before enabling WiFi, restart the Network Manager with:

sudo service network-manager restart

Then enable WiFi and it should connect.

|improve this answer|||||
  • This does nothing. Some processes used by network-manager won't restart after this command. – xyres Apr 13 '17 at 15:25
  • this doesn't work for me. After restarting network manager it shows same as "Authentication problem". Any other solution ?? – chetan Sep 24 '18 at 5:28
1

I too face same problem that you had I and I solved by.
Going into system settings; Click the Network Icon -> Edit Connections -> Select your Wifi Network (In your case select android-wifi ) -> Click Edit.

A dialogue box opes like this. enter image description here
Make sure you have checked Automatically connect to this Network...

After that Restart your computer.

Your Wifi Network is now available to use.

|improve this answer|||||
  • Unfortunately that didn't work. – Proletariat Jan 29 '16 at 10:07
  • This should not make any difference, it just tells the computer to connect to this network automatically if it is available. – Alexey Dec 28 '18 at 19:29
0

Try the following edits in /etc/NetworkManager/system-connections/android-wifi
You may use $sudo gedit android-wifi to edit it.

  • Add a line security=wifi-security
    after
    mac-address=A0:A8:CD:6F:0C:34
  • Replace the line
    psk-flags=1
    by psk="password wthout quotes"
  • Delete the last line.
    ip6-privacy=0

Now the file should look like this

[connection]
id=android-wifi
uuid=af9a2d23-c1e4-409d-a80e-d8c8271ba291
type=wifi

[wifi]
ssid=android-wifi
mode=ap
mac-address=A0:A8:CD:6F:0C:34
security=wifi-security

[wifi-security]
key-mgmt=wpa-psk
psk="password wthout quotes"

[ipv4]
method=shared

[ipv6]
method=auto
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.