2

I am using 64bit ubuntu 15.04 and in the hardwared; NVIDIA GeForce GT630 graphic card is attached. I have downloaded driver for this graphic card from the website given in the official website as shown in Fig.NVIDIA-GeForce GT630-website-screen shot, I have followed every method mentioned in different sites such as

  1. press Ctrl+alt+F1
  2. Type in, sudo service lightdm stop and then
  3. to run as root ls -i
  4. sh. graphic-driver.run
  5. sudo service lightdm start

I have crashed my Linux 15.04 3 times in this way and now I am unable to even re-install it which is a separate story. Please, help.

1
  • 1
    If you can't get a working installation how can we help you install the graphics drivers? It's never a good idea if you're a beginner to install video drivers from the web. It seems to fail a lot. If you get Ubuntu up and running again, just open the Additional Drivers app and select the NVIDIA driver there. – TheWanderer Jan 28 '16 at 12:48
3

There is an easier way of installing the latest Nvidia Drivers on ubuntu.

  • Open terminal Ctrl+alt+T
  • Remove all previous installations of Nvidia with :

    sudo apt-get remove --purge nvidia*

  • Update the repositories :

    sudo apt-get update

  • Install the Driver:

    sudo apt-get install nvidia-352

  • Finally Reboot :

    sudo reboot

Installed :)

NOTE: Your latest driver number may not be 352 Please make sure the latest available version of the Driver for your card On Nvidia (352.66 =>352)

Update: I removed the PPA from the answer because it is not necessary to add it when installing 352.

3
  • I followed your mentioned method and it worked. Hurrah! You have no idea how many times, I crashed my system in an attempt to install this driver. I am so thankful to you Severus Tux. I wish that you may succeed in every way of your life and be helped as you helped me. Lots of love and respect for you. – Abdul Mannan Jan 29 '16 at 0:45
  • @Abdul Mannan Glad to know that :) , If this answer solved your problem, please do not forget to click the grey tick ☑ at the left of the answer to make it green, which means Yes, this answer is valid ! – Severus Tux Jan 29 '16 at 1:15
  • :) Thanks Severus Tux, I was also going through this problem. I was having some problem while updating, some sort of failed PPA. I uninstalled it and now everything is perfectly fine. I am so thankful to you. – Abdul Mannan Jan 30 '16 at 2:17
2

It is just as easy as ...

Open a terminal and execute :

sudo apt-get update
sudo apt-get install nvidia-352
sudo reboot  

There is no need to do more ...

2
  • Thank you so much dear cl-nebox for your kind in time response. – Abdul Mannan Jan 29 '16 at 0:46
  • @AbdulMannan: As you've never accepted an answer on this site before: If this answer helped you, don't forget to click the grey at the left of this text, which means Yes, this answer is valid! ;-) – Fabby Jan 29 '16 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.