1

I have Asus N550j I install Ubuntu 14.04 it was workink fine utill I install nvidia 352 driver from Additional Drivers get blunk black screen I removed the driver the welcome login it came back but I could not login every time I try to login it go back to login screen I try to install the driver from nvidia web site ( NVIDIA-Linux-x86_64-352.79.run ) but still have the same problem now I couldn't go back and can not go forward My laptop have hybrid VGA 1- Intel i915 2- nvidia GeForce GTX 850m

Any Idea how to fix this issue Best regards Salim Hussein

  • Try adding this ppa and then installing it - ppa:graphics-drivers/ppa – Raphael Jan 28 '16 at 9:05
  • Hi Raphael I did try to add this but still the same problem – Salim Jan 28 '16 at 15:59
  • Would we ban "problems with nvidia driver" questions ?? – Croll Jan 28 '16 at 20:13
1

Follow this post to get into recovery mode:

How do I boot into recovery mode?

In essence:

  • Switch on your computer.
  • Wait until the BIOS has finished loading, or has almost finished. (During this time you will probably see a logo of your computer manufacturer.)
  • Quickly press and hold the Shift key, which will bring up the GNU GRUB menu. (If you see the Ubuntu logo, you've missed the point where you can enter the GRUB menu.) **
  • Select the line which starts with "Advanced options". *
  • Select the line ending with "(recovery mode)"

And then remove all NVIDIA propietary drivers following this other post:

How can I uninstall a nvidia driver completely ?

Summary:

sudo apt-get purge nvidia*
sudo apt-get install ubuntu-desktop
sudo rm /etc/X11/xorg.conf
echo 'nouveau' | sudo tee -a /etc/modules

Reboot your system.

EDIT

Perform additionally these 2 steps to reconfigure X with the nouveau driver:

sudo apt-get install nouveau-firmware
sudo dpkg-reconfigure xserver-xorg

and reboot!

  • HI Eduardo Lopez Thank you for your reply I did the steps but for " sudo rm /etc/X11/xorg.conf " the xorg.conf file is exist the the X11 folder and the problem still the same – Salim Jan 28 '16 at 14:22
  • Excuse me, I didn't catch that: What happens with the step where you delete the xorg.conf? You receive an error? – Eduardo López Jan 28 '16 at 14:40
  • I mean no file with xorg.conf name in /etc/X11 folder – Salim Jan 28 '16 at 15:59
  • But did you anyway executed the last step and rebooted? Issue this command in the command prompt, it should tell you where the xorg.conf file ist: "sudo find / -name 'xorg.conf'" – Eduardo López Jan 28 '16 at 16:25
  • Hi Eduardo Yes I did , and I did try to find the file as you told me and the result came no file found – Salim Jan 28 '16 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.