I have Windows laptop that can connect to my work thru a Cisco AnyConnect (version 3.1) VPN, then using the Windows 7 built-in Remote Desktop Client. It works OK.

I now also have a Ubuntu distro in which I've installed the following software: * openvpn * openconnect * libopenconnect2 * network-manager-openvpn * network-manager-openvpn-gnome * Remmina VNC

On Ubuntu When I login through the VPN connection after entering my username, my ordinary password and a magic number password supplied through my smartphone my computer says that I'm connected to the remote network. That seems to work OK.

Then I try using Remmina to connect to the computer. All of my permutations of an account fail with "Couldn't convert $DESKTOP_NAME to host address", with the macro being the exact human name (not an IP address) of the desktop.

On the Win7 Remote Desktop client I copied down the information from these fields and used them in a Remmina connection: * Computer * User * Display (full screen, 32-bit) (Remmina only lets me have 24-color) * Local: Use Window key combos in full screen * Devices: printers, clipboard * Remote Audio: Play it * Detect connection quality automatically, persist bitmap code, reconnect if dropped.

I have Remmina locations for most/all of this.

Other threads involving Remmina mention using a RDP panel as well, perhaps at security. Even though I installed a remmina-rdp plugin I don't see anything of it in the Remmina UI.

I tried enabling SSH tunneling. In it I tried the same user name as the "User:" I used elsewhere. No better results.

What is wrong here?

Thanks, Jerome.

  • Ok, so let's see - First: Your ubuntu system tells you you are connected to the network , but can you ping resources in it? And Second: Which system/OS are you trying to connect to once you get into the VPN? Also, post a couple of screenshots with your Remmina configuration, please. Jan 28, 2016 at 9:12
  • Sorry about the delay. On the Win7 box I used ipconfig to get its IP4. On the Ubuntu box I was NOT connected to the VPN and used ping on that IP4. Ping failed. I then connected with VPN and used ping again. This time ping returned values. However, using ping with the computer name didn't work. Jan 30, 2016 at 13:48
  • Putting Remmina screenshots here seems dubious. My config has (name: myname, group: AnyConnect, protocol: VNC, server: computer name from Windows Remote Client, user name: the same format in that remote client, like "company\myname", password: ****, colordepth: 24-bit, Quality: good, remote cursor: checked. Continued in next note. Jan 30, 2016 at 13:55
  • For SSH tunnel I tried it both ways. With SSH tunnel unclicked on a connection attempt things sit there and don't resolve. I have to force Remmina to quit. With SSH clicked and "same server at port 22" selected, SSH Auth: either myname or company\myname, password radio button selected the connection attempt quickly resolves to the usual "can't do this". Jan 30, 2016 at 13:56
  • Used apt-get to upgrade to Remmina 1.2. Got a few more choices but not a better result. Also tried to use the IP4 address in place of the computer name and tried clicking on "use loopback" for SSH. When I clicked on the "..." button, which browses the network for VNC server it found nothing. It says it is using the local domain, and I don't know enough to put something else here. Jan 30, 2016 at 14:21

1 Answer 1


For Remote Desktop Connections with Windows, you should use the RDP protocol in Remmina (The same used by Windows terminal services and the one used by any Windows installation if Remote Desktop Connections is enabled).

First of all, ensure that Remote Desktop Connections is enabled in your Windows machine. In Windows 7 and following the official documentation at http://windows.microsoft.com/en-us/windows7/allow-someone-to-connect-to-your-computer-using-remote-desktop-connection:

  • Open System Properties by clicking the Start button Picture of the Start button, right-clicking Computer, and then clicking Properties.

  • In the left pane, click Remote settings. Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

  • Under Remote Desktop, select one of the options to allow connections.

enter image description here

After that, an given that you are in a VPN, double check that you can ping the Windows7-System from your Ubuntu one. Tipically, unless you set it up, you will only be able to ping the IP.

Last but not least, use the following configuration in Remmina:

enter image description here


  • Protocol: RDP
  • Username: Account on the Windows7-System with enough rights
  • Password
  • DOMAIN: If the previous account is a domain account rather than a local one.
  • If you didn't set it up, do not try to use SSH tunneling.
  • This is a first-class representation of your prior comments. Thank you for your responses! I wish to bring down an earlier comment about the domain field -- if your Windows RDC login is first\second then "first" is your domain in Remmina and "second" is your username. Feb 9, 2016 at 4:06
  • Glad I could be of help :-) Feb 9, 2016 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .