3

I've read some postings on similar topics but none of them resolved my issue. I bought my notebook 2 weeks ago. After first wifi problems it worked well for some days. But now, I get almost any connection with Onboard wifi card Intel AC 7265. I tried to add these line to /etc/modprobe.d/iwlwifi.conf:

options iwlwifi 11n_disable=0

First I thought this helps, but I only got the wifi password request again and again. But now it's the same as before, can't connect to Fritzbox Cable 7360.

Next I found these two lines in my logs:

[    1.601664] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-15.ucode failed with error -2
[    1.601682] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-14.ucode failed with error -2

I got these firmware-files from https://github.com/OpenELEC/iwlwifi-firmware/tree/master/firmware and copied to /lib/firmware. With no effect.

What solution you recommend to connect wifi again. I used a USB wifi adapter but it works very slow and the connection breaks often.

Some sysinfos:

nunatak@zenbook:~$ ifconfig -a
lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX-Pakete:4159 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:4159 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:280204 (280.2 KB)  TX-Bytes:280204 (280.2 KB)

wlp2s0    Link encap:Ethernet  Hardware Adresse 34:13:e8:37:91:a5  
          UP BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:138 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:209 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:24680 (24.6 KB)  TX-Bytes:34095 (34.0 KB)

nunatak@zenbook:~$ lspci -nnk | grep 0280 -A2
02:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 59)
     Subsystem: Intel Corporation Dual Band Wireless-AC 7265 [8086:9110]
     Kernel driver in use: iwlwifi

nunatak@zenbook:~$ iwconfig
wlp2s0    IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

nunatak@zenbook:~$ rfkill list
1: phy0: Wireless LAN
     Soft blocked: no
     Hard blocked: no
2: asus-wlan: Wireless LAN
     Soft blocked: no
     Hard blocked: no
3: asus-bluetooth: Bluetooth
     Soft blocked: yes
     Hard blocked: no

nunatak@zenbook:~$ cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1


nunatak@zenbook:/$ dmesg | grep iwl
[    1.601664] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-15.ucode failed with error -2
[    1.601682] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-14.ucode failed with error -2
[    1.608685] iwlwifi 0000:02:00.0: loaded firmware version 25.30.13.0 op_mode iwlmvm
[    1.639162] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[    1.640538] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    1.640981] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    1.741289] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    1.778071] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
[    3.167514] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    3.168108] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    3.228866] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    3.229464] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    6.885733] iwlwifi 0000:02:00.0: No association and the time event is over already...
[    8.099342] iwlwifi 0000:02:00.0: No association and the time event is over already...
[    9.135990] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   10.859563] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   12.114818] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   13.103260] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   15.212138] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   17.292391] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   18.015380] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   21.675385] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   35.347746] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   52.529456] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   63.717210] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   65.371841] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   65.835744] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   70.561798] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   71.247224] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   72.281874] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   73.196575] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   76.857343] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   77.893446] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   78.924999] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   81.128964] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   85.214884] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   85.903202] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   87.039947] iwlwifi 0000:02:00.0: No association and the time event is over already...
[   95.034215] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  104.992122] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  112.852455] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  114.608110] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  256.792691] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  264.331317] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  269.724769] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  274.028032] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  274.717281] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  275.747285] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  276.781386] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  310.986914] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  322.207694] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  392.825547] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  451.701144] iwlwifi 0000:02:00.0: No association and the time event is over already...

[EDIT] As requested, the response of ls -al /lib/firmware | grep 7265:

nunatak@zenbook:~$ ls -al /lib/firmware | grep 7265
-rw-r--r--  1 root root  736844 Nov 20 17:18 iwlwifi-7265-10.ucode
-rw-r--r--  1 root root  880604 Mai 13  2015 iwlwifi-7265-12.ucode
-rw-r--r--  1 root root  885224 Aug  3 16:43 iwlwifi-7265-13.ucode
-rw-r--r--  1 root root   26989 Jan 27 14:10 iwlwifi-7265-14.ucode
-rw-r--r--  1 root root   25986 Jan 27 14:10 iwlwifi-7265-15.ucode
-rw-r--r--  1 root root  690452 Nov 24  2014 iwlwifi-7265-8.ucode
-rw-r--r--  1 root root  697828 Dez  1  2014 iwlwifi-7265-9.ucode
-rw-r--r--  1 root root  740436 Nov 20 17:18 iwlwifi-7265D-10.ucode
-rw-r--r--  1 root root 1002800 Mai 13  2015 iwlwifi-7265D-12.ucode
-rw-r--r--  1 root root 1008692 Aug  3 16:43 iwlwifi-7265D-13.ucode
-rw-r--r--  1 root root   27005 Jan 27 14:11 iwlwifi-7265D-14.ucode
-rw-r--r--  1 root root   27005 Jan 27 14:11 iwlwifi-7265D-15.ucode

I copied from github the files: iwlwifi-7265-14.ucode iwlwifi-7265-15.ucode iwlwifi-7265D-14.ucode iwlwifi-7265D-15.ucode

Ohhh, I think you are right. The files are to small. I got the html from github and not the file. ;)

[EDIT 28.01.16] There are many other WLANs in my neighborhood. The router shows 30 other wifi signals. Most of them on channel 11, which is automatically set by ours, too. There are 13 channels in total, some of them are not used by others at the time. Is it recommended to switch to such an unused channel?

  • The github link you posted includes the -14 and -15 firmware files which you say you copied to /lib/firmware. We wonder if they got copied correctly. Please edit your question to add: ls -al /lib/firmware | grep 7265 Welcome to askubuntu. – chili555 Jan 27 '16 at 14:56
  • Would you like a step-by-step to add the newer files? – chili555 Jan 27 '16 at 15:12
  • I copied them now. Downloaded the raw file formats from github and copied to /lib/firmware. But connection problem still exists.... – nunatak Jan 27 '16 at 15:23
  • I have a similar problem since the latest kernel update. Only began happening a few days ago and only on some wifi networks. What kernel are you running? – Michael Allen Jan 29 '16 at 11:27
  • uname -r returns 4.2.0-25-generic. – nunatak Jan 30 '16 at 10:42
6

Please install the latest 7265 firmware. From the terminal:

sudo apt-get update
sudo apt-get install git
git clone https://github.com/OpenELEC/iwlwifi-firmware.git
cd iwlwifi-firmware/firmware
sudo cp iwlwifi-7265*  /lib/firmware

Check:

ls -al /lib/firmware | grep 7265

Reboot and tell us if the performance is improved.

Check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

If these changes do not help, please try:

gksudo gedit /etc/modprobe.d/iwlwifi.conf

Change the line you added, options iwlwifi 11n_disable=0 to:

options iwlwifi 11n_disable=8

Proofread carefully, save and close the text editor. Reboot.

  • Ok, I followed these description, and reinstalled the firmware. I got connection. But very poor performance and a Network Password Request every 10 seconds. One step, but unfortunately not the solution. – nunatak Jan 27 '16 at 15:41
  • Please see my edit above in a few moments. – chili555 Jan 27 '16 at 15:53
  • Thanks for your detailed instructions. I set the Router to WPA2. 2,4 GHz n+b+g was already set. For now connections seems more stable and performance is good. Hope it remains. Thank you! – nunatak Jan 28 '16 at 11:48
  • Yes it was helpful! Nonetheless I still have trouble with my wifi connection. I often asked for the wifi password repeatedly. After restarting the router it works for a period of time. ;) Maybe there is still something wrong with network settings. – nunatak Feb 8 '16 at 15:05
0

for those guys who has Intel NUC, bear in mind bad throughput is due to bad design of the Intel 7265 Chip, if you turn on the Bluetooth it will interfere the WiFi signal so it is simple, turn the bluetooth off.

  • Can you provide any reference? – Mostafa Ahangarha Jan 24 '17 at 11:24
  • For what it's worth I tested this and it made no difference. Given there is no reference I'm calling BS on this. – Abe Petrillo Dec 18 '17 at 14:07
0

Had the same issue, disabling powersave worked for me:

iw wlan0 set power_save off

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.