1

I use open source driver for AMD HD6320 video card. I followed the instruction in this article Force Enable Hardware Acceleration in Firefox but if I try to play HD video in firefox it's very slow. How can I be sure that hardware acceleration is used? Thanks.

  • If you install proper driver of dedicated graphics Firefox will use Hardware acceleration from it. It did work for my NVIDIA graphics card – Edward Torvalds Jan 27 '16 at 11:55
  • I use open source video card driver. Is there any way to test if everything is OK with harware acceleration? Anyway it' strange that if I play HD 1024 video in firefox it's slow. – Victor Jan 27 '16 at 12:45
  • open source drivers are just fine, I use Intel's Open source drivers, also I have disabled my NVIDIA graphic card from BIOS. your firefox is slow maybe because you followed that link you have mentioned in question. if you can undo it, all things will be fine. Pus you dont have to follow any method to enable hardware acceleration it is done by default – Edward Torvalds Jan 27 '16 at 13:02
  • I just unset all changes I made in the article. The performance on 1080p still is very poor :( – Victor Jan 27 '16 at 13:18
  • you should mention this in question, and rename your question to something like poor performance on 1080p in firefox – Edward Torvalds Jan 27 '16 at 13:41
0

Check out (type as url): about:support This should give you info on supported features (like hardware rendering)

You can try to disable/uncheck hardware acceleration in Firefox. It may feel counter intuitive but has often worked for me. You can find it here:

Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" 

Another good thing to try is to install Chrome (or Chromium) and check that browser has the same problem. From experience I have had lagging in Firefox but Chrome worked fine.

If you do want to install the ati binary drivers you can go to

Ubunti Settings > Software & Updates > Tab: Additional drivers

Good luck!

  • Sure, I checked it before asking the question. I still think that it's driver issue. Anyway - the chrome has the same problem :( – Victor Jan 27 '16 at 14:23
  • You could try installing the binary driver. I added where you can find it to my answer. – E.F. Nijboer Jan 27 '16 at 14:25
  • I don't want to use fglx driver - only Xorg open source! I have a reason for that because after that I want to install Wayland instead of Xwindows and Wayland use only open source driver. Is there a way to know if the driver installed correctly? – Victor Jan 27 '16 at 14:41
  • to show info on the video card and driver used, try lshw -C video. This will show info on the card and the driver, in my case "driver=radeon" (I'm also using the open source drivers). You can also have a look in System Settings -> Details -> Overview: Graphics (my system reports -> "Gallium 0.4 on AMD RV730 (DRM 2.43.0, LLVM 3.6.2)" so I guess you should see something simmilar). For info on OpenGL you need glxinfo (install: sudo apt-get install mesa-utils) then type: glxinfo | grep "OpenGL". Hope this will help you any further. – E.F. Nijboer Jan 28 '16 at 8:47
  • The output of lshw -C video is *-display description: VGA compatible controller product: Wrestler [Radeon HD 6320] vendor: Advanced Micro Devices, Inc. [AMD/ATI] physical id: 1 bus info: pci@0000:00:01.0 version: 00 width: 32 bits clock: 33MHz capabilities: pm pciexpress msi vga_controller bus_master cap_list rom configuration: driver=radeon latency=0 – Victor Jan 28 '16 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.