2

My WiFi connection's been working fine for months and suddenly conked out. It's not the WiFi itself, as my phone and other machines can use it fine. It's my computer that can't connect to it (nor to any other WiFi networks previously used).

I figure it's something to do with the Broadcom drivers, but trying re-installs and purges and fresh installs of b43-firmware and similar things voted as best answers in other questions hasn't helped. At this point I've removed, installed, and re-installed a bunch of things so I don't know what exactly's going on.

Going to System > Software & Updates > Additional Drivers shows "Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)"

Here's my Wireless Info Script output. I'm currently connected using a wired (ethernet?) connection.

#### wireless info START

Report from: 26 Jan 2016 17:25 EST -0500

Booted last: 26 Jan 2016 16:53 EST -0500

Script from: 27 Sep 2015 00:34 UTC +0000

release

Distributor ID: Ubuntu Description: Ubuntu 14.04.3 LTS Release: 14.04 Codename: trusty

kernel

Linux 3.13.0-68-generic #111-Ubuntu SMP Fri Nov 6 18:17:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

desktop

Ubuntu

lspci

01:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359] Subsystem: Broadcom Corporation Device [14e4:0607]

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 07) Subsystem: Lenovo Device [17aa:2219] Kernel driver in use: r8169

lsusb

Bus 002 Device 002: ID 04ca:700b Lite-On Technology Corp. Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 002: ID 0a5c:21f3 Broadcom Corp. Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

PCMCIA card info rfkill

0: tpacpi_bluetooth_sw: Bluetooth Soft blocked: yes Hard blocked: no 2: hci0: Bluetooth Soft blocked: no Hard blocked: no

lsmod

brcmutil 15618 0 mac80211 630728 0 cfg80211 484040 1 mac80211 wmi 19177 0

interfaces

auto lo iface lo inet loopback

auto eth0 iface eth0 inet dhcp

ifconfig

eth0 Link encap:Ethernet HWaddr
inet addr:10.0.0.55 Bcast:10.0.0.255 Mask:255.255.255.0 inet6 addr: fe80::/64 Scope:Link inet6 addr: 2601:41:4200:478b:/64 Scope:Global inet6 addr: 2601:41:4200:478b:4939:9837:89b1:61f8/64 Scope:Global inet6 addr: 2601:41:4200:478b::8f14/128 Scope:Global UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:186174 errors:3 dropped:0 overruns:0 frame:3 TX packets:109429 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:222693024 (222.6 MB) TX bytes:12469299 (12.4 MB)

iwconfig

eth0 no wireless extensions.

lo no wireless extensions.

route

Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 10.0.0.1 0.0.0.0 UG 0 0 0 eth0 10.0.0.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0

resolv.conf

nameserver 75.75.75.75 nameserver 75.75.76.76 nameserver 127.0.1.1 search hsd1.pa.comcast.net

network managers

Installed:

NetworkManager

Running:

root 2555 1 0 06:53 ? 00:00:01 NetworkManager

NetworkManager info

NetworkManager Tool

State: connected (global)

  • Device: eth0 [Ifupdown (eth0)] ---------------------------------------------- Type: Wired Driver: r8169 State: connected Default: yes HW Address:

    Capabilities: Carrier Detect: yes Speed: 1000 Mb/s

    Wired Properties Carrier: on

    IPv4 Settings: Address: 10.0.0.55 Prefix: 24 (255.255.255.0) Gateway: 10.0.0.1

    DNS: 75.75.75.75 DNS: 75.75.76.76

    IPv6 Settings: Address: 2601:41:4200:478b::8f14 Prefix: 128 Gateway: fe80::bcd1:65ff:fe8c:8b68

    Address: 2601:41:4200:478b:4939:9837:89b1:61f8 Prefix: 64 Gateway: fe80::bcd1:65ff:fe8c:8b68

    Address: 2601:41:4200:478b: Prefix: 64 Gateway: fe80::bcd1:65ff:fe8c:8b68

    Address: fe80:: Prefix: 64 Gateway: fe80::bcd1:65ff:fe8c:8b68

    Address: 2601:41:4200:478b::8f14 Prefix: 128 Gateway: ::

    DNS: 2001:558:feed::1 DNS: 2001:558:feed::2

NetworkManager.state

[main] NetworkingEnabled=true WirelessEnabled=true WWANEnabled=true WimaxEnabled=true

NetworkManager.conf

[main] plugins=ifupdown,keyfile,ofono dns=dnsmasq

[ifupdown] managed=true

NetworkManager profiles

[[/etc/NetworkManager/system-connections/hhonors]] (600 root) [connection] id=hhonors | type=802-11-wireless [802-11-wireless] ssid=hhonors | mac-address= [ipv6] method=auto [ipv4] method=auto

[[/etc/NetworkManager/system-connections/HOME-8B65-5]] (600 root) [connection] id=HOME-8B65-5 | type=802-11-wireless [802-11-wireless] ssid=HOME-8B65-5 | mac-address= [ipv4] method=auto [ipv6] method=auto

[[/etc/NetworkManager/system-connections/MIFI-LIBERATE-VA97]] (600 root) [connection] id=MIFI-LIBERATE-VA97 | type=802-11-wireless [802-11-wireless] ssid=MIFI-LIBERATE-VA97 | mac-address= [ipv4] method=auto [ipv6] method=auto

[[/etc/NetworkManager/system-connections/AirPennNet]] (600 root) [ipv6] method=auto [connection] id=AirPennNet | type=802-11-wireless [802-11-wireless] ssid=AirPennNet [802-1x] ca-cert=/home/matthew/.certificates/Student-CA.pem [ipv4] method=auto

[[/etc/NetworkManager/system-connections/IM ON A BUFFALOOO]] (600 root) [connection] id=Network | type=802-11-wireless [802-11-wireless] ssid=Network | mac-address= [ipv4] method=auto [ipv6] method=auto

[[/etc/NetworkManager/system-connections/AirPennNet-Help]] (600 root) [connection] id=AirPennNet-Help | type=802-11-wireless | autoconnect=false [802-11-wireless] ssid=AirPennNet-Help | mac-address= [ipv6] method=auto [ipv4] method=auto

[[/etc/NetworkManager/system-connections/M-Network]] (600 root) [connection] id=M-Network | type=802-11-wireless [802-11-wireless] ssid=M-Network | mac-address= [ipv4] method=auto [ipv6] method=auto

iw reg get

Region: America/New_York (based on set time zone)

country 00: (2402 - 2472 @ 40), (3, 20) (2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

iwlist channels

eth0 no frequency information.

lo no frequency information.

iwlist scan

eth0 Interface doesn't support scanning.

lo Interface doesn't support scanning.

module infos

[brcmutil] filename: /lib/modules/3.13.0-68-generic/kernel/drivers/net/wireless/brcm80211/brcmutil/brcmutil.ko license: Dual BSD/GPL description: Broadcom 802.11n wireless LAN driver utilities. author: Broadcom Corporation srcversion: E81EE4CBB6A7A689150D93D depends:
intree: Y vermagic: 3.13.0-68-generic SMP mod_unload modversions signer: Magrathea: Glacier signing key sig_key: 45:B8:6D:4B:28:3F:CA:04:40:EC:04:F3:A7:A2:BC:67:5B:F4:69:44 sig_hashalgo: sha512

[mac80211] filename: /lib/modules/3.13.0-68-generic/kernel/net/mac80211/mac80211.ko license: GPL description: IEEE 802.11 subsystem srcversion: CD516ABEC909374CB2C52DC depends: cfg80211 intree: Y vermagic: 3.13.0-68-generic SMP mod_unload modversions signer: Magrathea: Glacier signing key sig_key: 45:B8:6D:4B:28:3F:CA:04:40:EC:04:F3:A7:A2:BC:67:5B:F4:69:44 sig_hashalgo: sha512 parm: max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int) parm: max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int) parm: beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int) parm: probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int) parm: ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211] filename: /lib/modules/3.13.0-68-generic/kernel/net/wireless/cfg80211.ko description: wireless configuration support license: GPL author: Johannes Berg srcversion: 695424C2F5CD23A91B67E25 depends:
intree: Y vermagic: 3.13.0-68-generic SMP mod_unload modversions signer: Magrathea: Glacier signing key sig_key: 45:B8:6D:4B:28:3F:CA:04:40:EC:04:F3:A7:A2:BC:67:5B:F4:69:44 sig_hashalgo: sha512 parm: ieee80211_regdom:IEEE 802.11 regulatory domain code (charp) parm: cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

module parameters

[mac80211] beacon_loss_count: 7 ieee80211_default_rc_algo: minstrel_ht max_nullfunc_tries: 2 max_probe_tries: 5 probe_wait_ms: 500

[cfg80211] cfg80211_disable_40mhz_24ghz: N ieee80211_regdom: 00

/etc/modules

lp rtc

modprobe options

[/etc/modprobe.d/blacklist-ath_pci.conf] blacklist ath_pci

[/etc/modprobe.d/blacklist-bcm43.conf] blacklist b43 blacklist b43legacy blacklist ssb blacklist bcm43xx blacklist brcm80211 blacklist brcmfmac blacklist brcmsmac blacklist bcma

[/etc/modprobe.d/blacklist.conf] blacklist evbug blacklist usbmouse blacklist usbkbd blacklist eepro100 blacklist de4x5 blacklist eth1394 blacklist snd_intel8x0m blacklist snd_aw2 blacklist i2c_i801 blacklist prism54 blacklist garmin_gps blacklist asus_acpi blacklist snd_pcsp blacklist pcspkr blacklist amd76x_edac blacklist eth1 blacklist eth1_cs blacklist lo blacklist lo1_cs

[/etc/modprobe.d/blacklist-rare-network.conf] alias net-pf-3 off alias net-pf-6 off alias net-pf-9 off alias net-pf-11 off alias net-pf-12 off alias net-pf-19 off alias net-pf-21 off alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf] remove iwlwifi \ (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \ && /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf] softdep mlx4_core post: mlx4_en

rc.local

exit 0

pm-utils udev rules

[/etc/udev/rules.d/70-persistent-net.rules]

PCI device 0x10ec:0x8168 (r8169)

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth", NAME="eth0"

PCI device 0x14e4:0x4359 (wl)

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan", NAME="wlan0"

dmesg

[ 513.278974] WARNING: CPU: 2 PID: 654 at /build/linux-FE4z5Q/linux-3.13.0/drivers/base/firmware_class.c:1092 _request_firmware+0x5f9/0xb20() [ 513.279041] Modules linked in: rfcomm bnep binfmt_misc uvcvideo btusb videobuf2_vmalloc videobuf2_memops bluetooth videobuf2_core videodev snd_hda_codec_realtek amd_freq_sensitivity snd_hda_codec_hdmi kvm snd_hda_intel thinkpad_acpi nvram snd_hda_codec joydev snd_hwdep fam15h_power serio_raw k10temp edac_core snd_seq_midi snd_seq_midi_event snd_pcm edac_mce_amd bcma rtsx_pci_ms memstick i2c_piix4 snd_rawmidi snd_page_alloc parport_pc snd_seq shpchp snd_seq_device ppdev snd_timer snd lp parport soundcore mac_hid dm_crypt crct10dif_pclmul crc32_pclmul ghash_clmulni_intel rtsx_pci_sdmmc aesni_intel radeon aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd i2c_algo_bit ttm psmouse drm_kms_helper ahci drm r8169 libahci rtsx_pci mii wmi video [ 513.279103] [] _request_firmware+0x5f9/0xb20 [ 513.279107] [] request_firmware+0x34/0x50 [ 513.279181] usb 3-2: firmware: fw-0a5c_21f3.hcd will not be loaded [ 513.279185] Bluetooth: can't load firmware, may not work correctly [ 513.358256] bcma-pci-bridge 0000:01:00.0: no hotplug settings from platform [ 514.082628] r8169 0000:03:00.0 eth0: link down [ 514.082742] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 546.902379] r8169 0000:03:00.0 eth0: link up [ 546.902409] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

#### wireless info END

Let me know if anything more would help.

Thanks!

EDIT 1: Per commented request,

sudo modprobe wl && dmesg | grep wl

returns

modprobe: FATAL: Module wl not found.

which I'm guessing means something...

EDIT 2: Per answer,

sudo apt-get update

Printed a bunch of stuff but appeared to throw no errors. However,

sudo apt-get install --reinstall bcmwl-kernel-source

ran into an issue with wl again. Here's the output:

The following NEW packages will be installed:
bcmwl-kernel-source
0 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
Need to get 0 B/1,512 kB of archives.
After this operation, 8,038 kB of additional disk space will be used.
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 413219 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.248+bdcom- 0ubuntu0.1_amd64.deb ...
Unpacking bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu0.1) ...
Setting up bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu0.1) ...
Loading new bcmwl-6.30.223.248+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 3.13.0-68-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed.
modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-68-generic

EDIT 3: Entering

sudo apt-get install linux-headers-generic

returned

linux-headers-generic is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

and entering

sudo apt-get install --reinstall bcmwl-kernel-source

returned

0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 5 not upgraded.
Need to get 0 B/1,512 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 413294 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu0.1_amd64.deb ...
Removing all DKMS Modules
Done.
Unpacking bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu0.1) over (6.30.223.248+bdcom-0ubuntu0.1) ...
Setting up bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu0.1) ...
Loading new bcmwl-6.30.223.248+bdcom DKMS files...
Building only for 3.13.0-68-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed. modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-68-generic

(sudo modprobe wl also returned FATAL: Module wl not found).

EDIT 4:

Entering

sudo apt-get install linux-generic

produced

The following extra packages will be installed:
linux-image-3.13.0-76-generic linux-image-extra-3.13.0-76-generic
linux-image-generic
Suggested packages:
fdutils linux-doc-3.13.0 linux-source-3.13.0 linux-tools
The following NEW packages will be installed:
linux-generic linux-image-3.13.0-76-generic
linux-image-extra-3.13.0-76-generic linux-image-generic
0 upgraded, 4 newly installed, 0 to remove and 5 not upgraded.
Need to get 52.0 MB of archives.
After this operation, 194 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-image-3.13.0-76-generic amd64 3.13.0-76.120 [15.2 MB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-image-extra-3.13.0-76-generic amd64 3.13.0-76.120 [36.8 MB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-image-generic amd64 3.13.0.76.82 [2,250 B]
Get:4 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-generic amd64 3.13.0.76.82 [1,780 B]
Fetched 52.0 MB in 3s (16.3 MB/s)
Selecting previously unselected package linux-image-3.13.0-76-generic.
(Reading database ... 413294 files and directories currently installed.)
Preparing to unpack .../linux-image-3.13.0-76-generic_3.13.0-76.120_amd64.deb ...
Done.
Unpacking linux-image-3.13.0-76-generic (3.13.0-76.120) ...
Selecting previously unselected package linux-image-extra-3.13.0-76-generic.
Preparing to unpack .../linux-image-extra-3.13.0-76-generic_3.13.0-76.120_amd64.deb ...
Unpacking linux-image-extra-3.13.0-76-generic (3.13.0-76.120) ...
Selecting previously unselected package linux-image-generic.
Preparing to unpack .../linux-image-generic_3.13.0.76.82_amd64.deb ...
Unpacking linux-image-generic (3.13.0.76.82) ...
Selecting previously unselected package linux-generic.
Preparing to unpack .../linux-generic_3.13.0.76.82_amd64.deb ...
Unpacking linux-generic (3.13.0.76.82) ...
Setting up linux-image-3.13.0-76-generic (3.13.0-76.120) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-76-generic
Found initrd image: /boot/initrd.img-3.13.0-76-generic
Found linux image: /boot/vmlinuz-3.13.0-68-generic
Found initrd image: /boot/initrd.img-3.13.0-68-generic
Found linux image: /boot/vmlinuz-3.13.0-66-generic
Found initrd image: /boot/initrd.img-3.13.0-66-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
done
Setting up linux-image-extra-3.13.0-76-generic (3.13.0-76.120) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-76-generic /boot/vmlinuz-3.13.0-76-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-76-generic
Found initrd image: /boot/initrd.img-3.13.0-76-generic
Found linux image: /boot/vmlinuz-3.13.0-68-generic
Found initrd image: /boot/initrd.img-3.13.0-68-generic
Found linux image: /boot/vmlinuz-3.13.0-66-generic
Found initrd image: /boot/initrd.img-3.13.0-66-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
done
Setting up linux-image-generic (3.13.0.76.82) ...
Setting up linux-generic (3.13.0.76.82) ...

which looked promising, but upon reboot WiFi still fails. However, now

sudo modprobe wl

produces

modprobe: ERROR: ../libkmod/libkmod.c:556 kmod_search_moddep() could not open moddep file '/lib/modules/3.13.0-76-generic/modules.dep.bin'

if that's relevant.

  • Please edit your question to include the result of: sudo modprobe wl && dmesg | grep wl – chili555 Jan 26 '16 at 22:42
  • @chili555: Added at the bottom above. – lamb_da_calculus Jan 26 '16 at 23:20
  • Run sudo apt-get install linux-generic, then reboot and try again. But you need to connect to internet first. You have different versions of headers and image. – Pilot6 Jan 27 '16 at 13:16
  • @Pilot6: See edit 4 above, thanks! – lamb_da_calculus Jan 27 '16 at 13:41
  • Now run sudo apt-get install --reinstall bcmwl-kernel-source. – Pilot6 Jan 27 '16 at 13:43
1

You need to update kernel and headers first. Run in terminal

sudo apt-get install linux-generic

Reboot and run:

sudo apt-get install --reinstall bcmwl-kernel-source
  • This finally worked, thanks! I'm posting from WiFi now. For future reference, do you have any idea how the header-image mismatch occurred? I remember going back and deleting old headers/images a couple of times in the past after my Boot ran out of memory, but that hasn't happened in a while, and I'm not sure if it's related. – lamb_da_calculus Jan 27 '16 at 13:51
2

The correct driver for your device, wl, has gone missing. Let's try to reinstall it:

sudo apt-get update
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

Please post any errors, warnings, etc.

We see this:

Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed.

Please try:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl
  • See bottom of above for my response. – lamb_da_calculus Jan 27 '16 at 1:28
  • The problem seems to be fixed now. Pilot6's answer actually got it working, but I'm guessing your answer started the fix, so I voted this up too. – lamb_da_calculus Jan 27 '16 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.