Problem above. If you need any more information feel free to ask me.

movioli@movioli-Lenovo-G50-30:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 105b:e065 Foxconn International, Inc. BCM43142A0 Bluetooth module
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 004: ID 0bda:579a Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
movioli@movioli-Lenovo-G50-30:~$ rfkill list
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
movioli@movioli-Lenovo-G50-30:~$  dmesg | grep -i bluetooth
movioli@movioli-Lenovo-G50-30:~$ uname -a
Linux movioli-Lenovo-G50-30 4.2.0-25-generic #30-Ubuntu SMP Mon Jan 18 12:31:50 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
movioli@movioli-Lenovo-G50-30:~$ hciconfig -a

After trying the tutorial mentioned in the comments below

movioli@movioli-Lenovo-G50-30:~$ sudo cp ~/BCM.hcd /lib/firmware/brcm

movioli@movioli-Lenovo-G50-30:~$ sudo service bluetooth status ● bluetooth.service - Bluetooth service Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled) Active: active (running) since Sa 2016-01-30 19:49:59 CET; 16min ago Docs: man:bluetoothd(8) Main PID: 638 (bluetoothd) Status: "Running" CGroup: /system.slice/bluetooth.service └─638 /usr/lib/bluetooth/bluetoothd


1 Answer 1


In addition to the firmware installation, you need to install a kernel module. Run

wget https://launchpad.net/~hanipouspilot/+archive/ubuntu/bluetooth/+files/btusb-bcm105b-dkms_0.1_all.deb
sudo apt-get install btusb-bcm105b-dkms_0.1_all.deb

Then reboot.

  • after several restarts it bluetooth is now working. thank you guys Jan 31, 2016 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.