While browsing through CCSM I clicked Advanced, I guess, and whole GUI crashed, I've seen ONLY a wallpaper with some graphical noise on it. I rebooted and all I see is Desktop with icons on it and menu at the upper bar "File|Edit|View.." etc. without tools to shutdown or logout and that would be all. No dash, none of keyboard shortcuts working, no way for me to open console to try to fix it. Wanted to reset X via console (Ctrl+Alt+F1) but all I see is graphical noise, nothing readable, commands I tried to put without seeing them didn't work either. Please help.

Logging into different GUI helped (Ubuntu -> Ubuntu 2D), although anyone could help how to reset Ubuntu's GUI settings?

2 Answers 2


I had the same experience last night and I was wondering what was going on. However,what I did was I simultaneously pressed CTRL+ALT+T to open the Terminal and type ccsm and the 'CompizConfig Setting Manager' popped up. I clicked to open OPENGL moved on to General and unticked 'Synch to VBlank' and Texture to Good from better.Ticked 'Ubuntu Unity Plugins' and closed it. I restarted my system and every icon came back as normal, I didn't know this unrelated thing how it solved the problem but it did. I would have done a system restore from the terminal but I had no backup. I hope you can find something useful from it. Thank you.

NB: After getting my normal Dektop back I uninstall CompizConfig Setting Manager for me not to accidentally repeat the same process. I think there is something with the CCSM that is responsible for that problem though.

  • heeey, it worked, you are genius! I'd have voted up if i'd be able to ;/
    – Tomasch
    Oct 26, 2011 at 23:25

CCSM is buggy (it's a shame Unity relies on that poor application to offer very limited customizability). It happens to me too, every once and then. Usually, I get things sorted out by simply killing Xorg (which takes me to the login screen). It can be done by hitting Ctrl+Alt+F2, logging in the console, and typing:

sudo killall Xorg

When the above solution doesn't fix it, in the console, I reset the unity settings as follows:

unity --reset

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.