5

After more than five years of setting up Ubuntu on various computers, for the first time I am at the verge of giving up on a case.

The issue is setting up proper graphics drivers for the NVIDIA GeForce GTX 960. The default Nouveau driver does not seem to recognize resulutions above 1024, I don't think it will support multi-monitor, and overall I think I will get suboptimal performance. That leaves the official drivers from NVIDIA. I tried installing them from the "Additional drivers" utility in Ubuntu. Installation seems to finish without errors. I then reboot, get a quick Ubuntu splash screen (little progress bar of dots on a purple background), and then it drops to a completely black screen with a little blinking prompt line in the upper left. It never seems to move on from that, so the only option is to reboot. This will then lead to the same place, unless I go to recovery mode and purge everything NVIDIA.

  • This was all done on a clean install of 14.04 and 15.10 (I tried both).
  • Monitor is connected with DisplayPort.

So I am out of ideas, and am hoping that someone here might help. If someone knows a way of setting up multi-monitor with Nouveau, that could also be an alternative.

Things I have tried:

List of relevant hardware:

  • CPU: Intel i7 5820K (Haswell)

  • Motherboard: ASUS X99-A

  • RAM: DDR4 2133MHz

  • GPU: MSI GeForce GTX960 2GB

Errors I have seen here and there at boot/install. Not sure about relevance:

  • "acpi pcc probe failed"
7

So I finally got it working, in one more iteration of trying different things. (Yes there were many attempts...)

This is what I did:

  • Connect a monitor to the DVI-port.
  • Fresh install of Ubuntu 15.10
  • Set boot option "nomodeset" using the program boot-repair.
  • Set blacklist.conf according to here: http://ubuntuforums.org/showthread.php?t=2263316 This included fixing the typo "nouveua".

    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv
    blacklist lbm-nouveau
    options nouveau modeset=0
    alias nouveau off
    alias lbm-nouveau off 
    
  • Switch to non-graphical terminal: ctrl+alt+F1
  • Kill GUI: sudo service lightdm stop
  • sudo apt-get install nvidia-352
  • nvidia-xconfig
  • Start GUI again: sudo service lightdm start

And then it worked!

I think having the monitor connected to the DVI-port while installing the driver is important. My previous attempts used the DP-port while installing the driver. Switching to DVI after driver install did not help. I connected two additional monitors to DP-ports, and my desktop was extended flawlessly. So it's not that DP doesn't work, but it may be a requirement of at least one DVI monitor to get it set up correctly.

Note that I myself do not have a full understanding of what I did with blacklist.conf and the boot option "nomodeset". Neither do I know if it was crucial to do the install in a ctrl+alt+F1 with a killed GUI. One or many of these things may have been unnecessary. Perhaps others will enlighten us.

  • i tried for days getting my nvidia 960 to work with ubuntu 16.10 using every possible solution i could find in the web. this was the ONLY source that really worked. thanks a lot!! – fischermatte Oct 23 '16 at 21:27
5

Generally you should use the NVIDIA drivers from the Ubuntu repositories. But when there are problems with the drivers ... then you can install the latest official NVIDIA drivers from the GPU Drivers PPA. This often leads to properly working graphics - especially on new NVIDIA adapters.

First of all uninstall the currently installed NVIDIA drivers from the official Ubuntu repositories.

Highlight the Ubuntu entry in the GRUB boot menu and press the E key.
Add nouveau.modeset=0 to the end of the linux line - press F10 to boot.

On the login screen press Ctrl+Alt+F1 - enter your user name and your password - execute :

sudo apt-get purge nvidia*  
sudo reboot   

Now install the latest official NVIDIA drivers for GTX 960 from the Proprietary GPU drivers PPA.

Highlight the Ubuntu entry in the GRUB boot menu and press the E key.
Add nouveau.modeset=0 to the end of the linux line - press F10 to boot.

On the login screen press Ctrl+Alt+F1 - enter your user name and your password - execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358
sudo reboot
  • Thanks for a thorough answer. As you may see below, I suddenly got it working myself before I read it. I think I have tried what you posted before though, but my monitor was connected with DisplayPort at the time. Using the DVI for my main monitor may have been the missing piece, but I do not know. Also, i ran nvidia-xconfig, which may or may not have helped. – Eskil Jan 26 '16 at 15:40

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.