13

I am running inkscape on kubuntu 15.10 and the tootips are unreadable. The are white on a light gray background. Everything is quite vanilla.

Is there a fix? Or a configuration setting?

Thanks. --Len

I am running fvwm as my KDEWM. I checked and if I use fvwm directly (not under PLASMA) the tooltips are OK. I installed the menu package and tried accessing inkscape using the generated Debian menus. The tooltips are OK from there; however, when I launch inkscape from the KDE menu or the command line, I still have the white-on-light-grey problem. At any rate, no longer a show stopper.

4
  • I think you may have to install an alternate theme. I run Inkscape in gnome and the tooltips are fine. On the other hand, the Ubuntu Software Center is almost illegible.... Jan 26 '16 at 4:57
  • I checked on my laptop (kubuntu 14.04) and inkscape (0.48) tooltips are OK. On my desktop (kubuntu 15.10) and inkscape(0.91) has the tooltip problem as described. O.w. the two systems are comparable. Both uptodate. I'm not sure what you mean by changing the Theme.
    – LenB
    Jan 26 '16 at 14:07
  • Themes are the controlling aspect of how the desktop looks and feels on your computer. New themes can be downloaded from sites such as this one, and can be simple set of new icons or colors, or include new window styles and behaviours. I'm really surprised that your laptop and your desktop system look differently - do they display most colors the same? Jan 26 '16 at 15:10
  • I haven't noticed significant differences before. The thing that surprises me, however, is that running from the Debian Menu gives different results than running from KDE.
    – LenB
    Jan 26 '16 at 19:47
12

Disabling "apply colors to non Qt applications" worked for me.

If you do not want KDE to override your GTK settings, select Colors -> Options in the System Settings and disable the checkbox Apply colors to non-Qt applications

Sources: https://bugs.kde.org/show_bug.cgi?id=355540 https://classicforum.manjaro.org/index.php?topic=29859.0

Before:

Before

After:

After

1
  • I can confirm this works perfectly on KDE Plasma 5.13 with Inkscape 0.91 on Neon GNU/Linux. Thank you @Carlos. Dec 22 '19 at 16:32
3

For me(on Kubuntu 15.10), it worked by using Oxygen-gtk theme for GTK2 as well as GTK3. Orion and Pearl themes did not work. Now the interface and tool tips, both look native.

1

Appending the following text to ~/.gtkrc-2.0-kde4 worked for me:

style "gnome-color-chooser-tooltips"
{
bg[NORMAL] = "#FFFFAF"
fg[NORMAL] = "#000000"
}
widget "gtk-tooltip*" style "gnome-color-chooser-tooltips"

I found it in this discussion.

0

Same issue on Kubuntu 18.04. Solution is now in System settings > Appearance > Application Style > GNOME Application Style. Check "Prefer Dark GTK3 Theme".

0

Tryout this workaround:

  • remove line (about 38) "gtk-tooltip" style "ToolTip" from ~/.config/gtkrc-2.0
  • restart the gtk-application (no display manager)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.