1

Linux newbie here.

I'm trying to breathe new life into my 8 year old Macbook by replacing OS X 10.6.8 with a Linux distro. While I'm trying to figure out which distro to choose, I ran into the problem that Ubuntu 14.04 doesn't even boot from the USB stick that I created, so I can't even test it or install it.

I'm planning to install a new 250GB SSD and move my current 250GB HDD to the optical bay drive, hence the need for me to use a USB drive (I've read about all the issues that Macbook has with USB sticks already).

I tried this method, installed a bootloader on the USB, and was able to EFI boot Lubuntu 14.04 from the USB stick. I was able to do this for Ubuntu 11.10 as well. However, when I tried it for Ubuntu 14.04, it would Load Linux, Load the RAMDisk, then tell me to "fasten your seatbelts now, we are booting the kernel. This may take a while, please be patient..."

And immediately goes to a completely black screen.

I left it like that for a couple hours, since the fan was running the entire time, but nothing happened. There's no cursor to move, no command line to type things, nothing. Just a black screen, so it seems like a different issue from the ones I've read about on here.

Any idea how I can fix this? Seems only to be a problem for Ubuntu 14.04, considering I was able to boot Lubuntu 14.04 and Ubuntu 11.10 from my USB sticks with the same exact method.

Here are the specs for my Macbook:

Early 2008 black Macbook 4,1
2.4 GHz Intel Core 2 Duo
2GB RAM (Upgrading to 4GB once I get the hardware)
250GB HDD (Upgrading to 250 GB SSD + 250GB HDD once I get the hardware)
OS X Snow Leopard 10.6.8

I'm using a 2GB USB flash drive.

Thanks in advance!

  • Try Ubuntu 15.10 – TheWanderer Jan 25 '16 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.