2

I have an application with port 9901 and hosted in online server.
If i check this application from the same server with http://127.0.0.1:9901/ or http://127.0.0.1:9901/ the application is run correctly.

But if i access from another computer with http://domain.com:9901 or http://x.x.x.x:9901 (x is server IP). I could not get any response.

What could be wrong?

Here is the netstat of my server:

$ netstat -l | grep 9901
tcp6       0      0 [::]:9901               [::]:*                  LISTEN
  • 1
    Are you positive that you're using the right IP address? what you get from ifconfig isn't necessarily accurate. See here: askubuntu.com/questions/95910/…. As for domain name, have you set up this server with a nameserver/dns/etc.? – Mitch Jan 25 '16 at 17:43
  • @Musher yes, i positive my ip address is right – GusDeCooL Jan 26 '16 at 8:52
1

I was battling with the same issue with my Node.js web app just yesterday, and eventually found the culprit and the solution.

The reason for my issue was because I did not set up the port forwarding on my router (BT Home Hub 5). When you're behind a router, and you want to set up a server that is externally visible, you need to "tell" the router which device to forward incoming requests to when they are made with your server's port.

Every router's documentation is different, so you'll need to look it up, but it shouldn't be too difficult to figure out.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.