4

I am trying a local installation of the juju charms.

  1. Deply charm on machine1

  2. copy deb files from /var/cache/apt/archive to /root/test on machine2

  3. Modify the /etc/apt/sources.list to /root/test

  4. apt-get update

  5. When I try to deploy the charm on the machine2, I get the following error:

    warning: the following packages cannot be authenticated!
    

I did the search on error and tried few tricks like apt-key update but it did not work. How to resolve this?

5
  • Which command exactly leads to the error message in step 5? Jan 25, 2016 at 16:11
  • @David, I tried also the same search which appeared as google relevant suggestions. I tried few answers mentioned as part of search result. but none worked. When I deploy mysql, rabbitmq-server, some of the packages python-chardet-whl are being installed. If I install python-chardet-whl on command prompt with the option --force--yes, the package is installed. But if I try the installation without --force-yes option it fails Jan 25, 2016 at 16:54
  • Should I change the question to soething relevant like this - Can debian packages from one machine can be installed on another? Jan 25, 2016 at 16:55
  • Maybe… I'm not sure. You should definitely include a reference to the linked question in your question with a statement, that you tried all its answers unsuccessfully. You should also clarify, which command(s) lead(s) to the error message in your step 5. Jan 25, 2016 at 23:19

1 Answer 1

2

Try to add --force-yes option when you do the apt-get install. It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.